Bug 52980 - grubby doesnt add default properly
Summary: grubby doesnt add default properly
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mkinitrd   
(Show other bugs)
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-31 21:33 UTC by Adrian Likins
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-02 22:10:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
grub.conf that fails to have it's "default=X" param set (636 bytes, text/plain)
2001-08-31 21:34 UTC, Adrian Likins
no flags Details

Description Adrian Likins 2001-08-31 21:33:28 UTC
Description of Problem:

grubby seems to fail to add a "default=X" entry to the /boot/grub/grub.conf


Version-Release number of selected component (if applicable):
mkinitrd-3.1.6-1


How Reproducible:
see soon to be attached grub.conf
try running:

grubby --set-default /boot/vmlinuz-2.4.7-0.9.1 

And see that the grub.conf does not include a default=X line.



Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:

Comment 1 Adrian Likins 2001-08-31 21:34:27 UTC
Created attachment 30415 [details]
grub.conf that fails to have it's "default=X" param set

Comment 2 Jeremy Katz 2001-08-31 21:49:35 UTC
grubby didn't exist until mkinitrd 3.2 or so... this case should be fixed as of
mkinitrd 3.2.4

Comment 3 Joshua Jensen 2004-02-02 21:32:27 UTC
This is STILL BROKEN, even in RHEL3.  Please please fix!

Comment 4 Joshua Jensen 2004-02-02 22:10:23 UTC
I'll pull my foot out of my mouth... and say that the above example
does work.

*However*, this doesn't:

grubby --set-default 2.4.7-0.9.1

Turns out, grubby from RHL 7.3 says STRING when explaining what should
come after --set-default.  RHEL3's --help and man page now says
"kernel path".  That's cool.


Note You need to log in before you can comment on or make changes to this bug.