Bug 529827 - guest_u user not able to run ps
guest_u user not able to run ps
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-20 06:21 EDT by Petr Šplíchal
Modified: 2016-05-31 21:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-20 08:32:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Šplíchal 2009-10-20 06:21:28 EDT
Description of problem:

User in guest_u role cannot find out what processes he is running
because he is denied to acces the /proc filesystem.

Version-Release number of selected component (if applicable):
selinux-policy-3.6.32-27.fc12.noarch

Steps to Reproduce:
ps -Z
  
Actual results:
Error: /proc must be mounted
  To mount /proc at boot you need an /etc/fstab line like:
      /proc   /proc   proc    defaults
  In the meantime, run "mount /proc /proc -t proc"

Expected results:
LABEL                             PID TTY          TIME CMD
guest_u:guest_r:guest_t:s0      15094 tty2     00:00:00 bash
guest_u:guest_r:guest_t:s0      16577 tty2     00:00:00 ps


Additional info:

type=AVC msg=audit(1256033931.373:317): avc:  denied  { create } for  pid=15094 comm="bash" scontext=guest_u:guest_r:guest_t:s0 tcontext=guest_u:guest_r:guest_t:s0 tclass=netlink_audit_socket

type=SYSCALL msg=audit(1256033931.373:317): arch=40000003 syscall=102 success=no exit=-13 a0=1 a1=bfa64f00 a2=82da008 a3=1 items=0 ppid=1551 pid=15094 auid=502 uid=502 gid=502 euid=502 suid=502 fsuid=502 egid=502 sgid=502 fsgid=502 tty=tty2 ses=20 comm="bash" exe="/bin/bash" subj=guest_u:guest_r:guest_t:s0 key=(null)
Comment 1 Daniel Walsh 2009-10-20 08:32:16 EDT
Fixed in selinux-policy-3.6.32-29.fc12

Note You need to log in before you can comment on or make changes to this bug.