Bug 529842 - virt-manager: Storage browser should change window title when choosing ISO
virt-manager: Storage browser should change window title when choosing ISO
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks: F13VirtTarget
  Show dependency treegraph
 
Reported: 2009-10-20 08:36 EDT by Yunlin Fang
Modified: 2009-12-03 18:57 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-03 18:57:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch of choosecd.py (1.01 KB, patch)
2009-10-20 08:38 EDT, Yunlin Fang
no flags Details | Diff
This is the patch of create.py (1.01 KB, patch)
2009-10-20 08:40 EDT, Yunlin Fang
no flags Details | Diff
screenshot 1 before patched. (165.85 KB, image/png)
2009-10-20 08:41 EDT, Yunlin Fang
no flags Details
screenshot 2 before patched. (183.65 KB, image/png)
2009-10-20 08:41 EDT, Yunlin Fang
no flags Details
screenshot 1 after patched. (539.96 KB, image/png)
2009-10-20 08:42 EDT, Yunlin Fang
no flags Details
screenshot 1 after patched. (282.65 KB, image/png)
2009-10-20 08:43 EDT, Yunlin Fang
no flags Details

  None (edit)
Description Yunlin Fang 2009-10-20 08:36:59 EDT
Description of problem:
Hi,

When I use Fedora 11 to create a new virtual machine by local install media(CDROM), in the window that determine use ISO image or CDROM, if I choose use ISO image way to install my virtual machine and click "browse" button, it show me a "Choose Volume" dialog box, not a dialog box use to choose a iso image file. We need a file dialog box to choose the iso file, not a dialog box named "Choose Volume" and show me the interface about storage pool.

Also, the problem(maybe ?) happened in the window to change virtual machine's iso setting.

This problem just in Fedora, RHEL's virt-manager is OK. When I create a virtual mechine, I click the browse button to choose a ISO image file, it will show me a file dialog box to choose the file, not a dialog called "Choose Volume".

We can choose file by the button "Browse Local", but I think it just "a luck". In fact, this button is used to choose the Logical Volume if the Volume Group has not register to virt-manager's storage pool.


Version-Release number of selected component (if applicable):
virt-manager-0.7.0-7.fc11.i586

How reproducible:


Steps to Reproduce:

One way:
1. execute "virt-manager" command
2. click "New" button to create a virtual machine
3. enter the Name and choose "Local install media(ISO image or CDROM)"
4. choose "use ISO image" and click "Browse" button

Another way:
1. execute "virt-manager" command
2. double click a virtual machine existed to open it
3. click "Details" tab
4. choose "Device hdc" and click "connect" button to choose a ISO image
5. Choose the radio button to use ISO image and click the "browse" button

Actual results:

class "_browse_file" is used to show a "storage pool dialog box", not a "normal file dialog box", maybe some engineer mistake it.

I saw the source of virt-manager, I saw that the "storage pool" dialog box class is named "_browse_file", maybe some engineer mistake it to "a normal file dialog box", so someone use it in the place where need to use the "normal file dialog box". It is wrong.
The two files:
/usr/share/virt-manager/virtManager/create.py
/usr/share/virt-manager/virtManager/choosecd.py 
have this problem(maybe I can call it "problem"?)

Expected results:
We need a file dialog box to choose the iso file, not a dialog box named "Choose Volume" and show me the interface about storage spool when we need to choose a ISO image.

Additional info:
Attachments are my screenshots and patch about create.py and choosecd.py .
Usage:
patch create.py < create.patch
patch choosecd.py < choosecd.patch
Comment 1 Yunlin Fang 2009-10-20 08:38:40 EDT
Created attachment 365337 [details]
patch of choosecd.py

This is my patch.
Usage:
patch choosecd.py < choosecd.patch
Comment 2 Yunlin Fang 2009-10-20 08:40:22 EDT
Created attachment 365340 [details]
This is the patch of create.py

This is the patch of create.py
Usage:
patch create.py < create.patch
Comment 3 Yunlin Fang 2009-10-20 08:41:22 EDT
Created attachment 365341 [details]
screenshot 1 before patched.

screenshot 1 before patched.
Comment 4 Yunlin Fang 2009-10-20 08:41:55 EDT
Created attachment 365342 [details]
screenshot 2 before patched.

screenshot 2 before patched.
Comment 5 Yunlin Fang 2009-10-20 08:42:41 EDT
Created attachment 365343 [details]
screenshot 1 after patched.

screenshot 1 after patched.
Comment 6 Yunlin Fang 2009-10-20 08:43:08 EDT
Created attachment 365344 [details]
screenshot 1 after patched.

screenshot 1 after patched.
Comment 7 Cole Robinson 2009-10-21 10:54:49 EDT
Thanks for the patch, however this behavior is intended. We want to offer the storage volume browser to users looking for ISO media. You can still click the 'browse' button the bottom left of the storage browser to launch the typical GTK file browser.

That said, the window title should certainly be changed because it comes off sounding like a bug. A patch to change the storage browser title would be appreciated.
Comment 8 Yunlin Fang 2009-10-21 22:21:50 EDT
Hi, crobinso,

Could you tell me do you plan to offer users something like "ISO spool" thak we can add ISO in the spool and we can choose ISO from the spool that we can save the time to find the ISO file in the filesystem ?

Best Regards.
恭喜发财。
Comment 9 Cole Robinson 2009-10-22 08:53:50 EDT
Just a correction, it is 'pool' not 'spool'. A plain directory can be a 'storage pool', and all files in that directory are listed as 'storage volumes'. So, users should set up a storage pool that points to the directory where the keep all their install media.

You can set up storage pools via Edit -> Host Details -> Storage -> '+'
Comment 10 Mark McLoughlin 2009-10-29 12:48:28 EDT
Doesn't sound too serious, so putting on F13VirtTarget
Comment 11 Cole Robinson 2009-11-16 16:22:00 EST
We now appropriately set the ISO browser title upstream. Moving to POST.
Comment 12 Cole Robinson 2009-12-03 18:57:15 EST
Not really critical to backport to F11 IMO, but this should now be in rawhide with virt-manager-0.8.1, so closing.

Note You need to log in before you can comment on or make changes to this bug.