Bug 52992 - Won't start GUI in runlevel 5
Won't start GUI in runlevel 5
Product: Red Hat Public Beta
Classification: Retired
Component: kdebase (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-09-01 02:05 EDT by Mike Chambers
Modified: 2007-04-18 12:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-09-03 12:23:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
My inittab script from the latest up2date today (1.71 KB, text/plain)
2001-09-01 02:13 EDT, Mike Chambers
no flags Details

  None (edit)
Description Mike Chambers 2001-09-01 02:05:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
When rebooting and /etc/inittab is set with runlevel 5, system only boots 
to command line not the KDE GUI login screen or auto login.  KDE or gnome 
will start with startx once you login.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.Install Fresh Roswell2 complete/everything
2.Configure KDE Login Manager to autologin
3.Configure system to startup with runlevel5
4.Run up2date and update everything

Actual Results:  System only goes to command line even thought it looks 
like all the services for runlevel5 were started.

Also I noticed after running up2date and logging out of KDE before 
rebooting, all the users were shown at the KDE Login screen instead of 
just the couple I had set previously.

Expected Results:  System should go to GUI login screen and auto login if 
set up to do so prior to up2date or even if set after up2date as it still 
doesnt' work.

System should have only shown me the users I had set in Login Manager 
instead of all users when I logged out of KDE to reboot after running 

Additional info:

In General, after fresh custom/complete install of Roswell2, then running 
up2date and updating everything, that is when the problem arose.
Comment 1 Mike Chambers 2001-09-01 02:13:58 EDT
Created attachment 30494 [details]
My inittab script from the latest up2date today
Comment 2 Mike Chambers 2001-09-01 02:14:51 EDT
[reddawg@goober reddawg]$ rpm -q initscripts
Comment 3 Joe Christy 2001-09-02 12:35:56 EDT
I see the same problem, first noticed after doing an up2date Sunday 9/2 at 08:30

Here's what my /var/log/messages reveals:
 - After first logout:
Sep  2 09:00:08 moby kde(pam_unix)[1138]: session closed for user root
Sep  2 09:00:08 moby kdm_config[15420]: Cannot open config file
Sep  2 09:00:09 moby modprobe: modprobe: Can't locate module char-major-81
Sep  2 09:00:12 moby kdm[15427]: can't execute "/usr/share/config/kdm/Xsetup"
(err 2)
 - Then I noticed hosed kdm login panel, and rebooted (as I was going to
 - Upon reboot:
Sep  2 09:03:18 moby kdm_config[1130]: Cannot open config file
Sep  2 09:03:18 moby kdm[1123]: Cannot open access control file
/usr/share/config/kdm/Xaccess, no XDMCP reqeusts will be granted
 - kdm apparently starts, but no X.

My hypothesis is that /usr/share/config/kdm needs to be non-empty; I blame
[root@moby root]# ls -al /usr/share/config/kdm
total 8
drwxr-xr-x    2 root     root         4096 Sep  2 08:26 .
drwxr-xr-x    6 root     root         4096 Sep  2 08:26 ..
[root@moby root]# rpm -qf /usr/share/config/kdm
Comment 4 Joe Christy 2001-09-02 12:59:30 EDT
Apparently, the missing files used to be elsewhere ( /home/etc is the copy of
/etc I made before updating from seawolf to roswell2 ):

[root@moby root]# locate kdmrc
[root@moby root]# locate Xaccess
[root@moby root]# locate Xsetup
Comment 5 Joe Christy 2001-09-02 20:34:34 EDT
As you've probably guessed, and I should have mentioned earlier, I'm using kdm
as my default login manager. So, I was motivated to find a fix/workaround.

Here is my proposed fix (i.e this worked for me, your mileage may vary):

[root@moby root]# cp -p /etc/X11/xdm/Xaccess /usr/share/config/kdm/
[root@moby root]# cp -p /etc/kde/kdm/kdmrc /etc/kde/kdm/kdmrc.dist7.1.94
[root@moby root]# emacs /etc/kde/kdm/kdmrc
### change DaemonMode to default, i.e. cooment out DaemonMode=false
[root@moby root]# cp -p /etc/kde/kdm/kdmrc /usr/share/config/kdm/kdmrc

Comment 6 Mike Chambers 2001-09-02 21:30:59 EDT
Your solution worked for me too, good job.  I had to go back to Login Manager 
and redo that but it kept the settings and worked.  Only thing it wouldn't do 
was when I changed the background colors it wouldn't keep the settings and 
reverted back to the default RedHat background.
Comment 7 Bill Nottingham 2001-09-02 21:37:19 EDT
assigning to kdebase; AFAICT, initscripts is working OK here.
Comment 8 Bernhard Rosenkraenzer 2001-09-03 07:17:35 EDT
Try installing the XFree86-xdm package, looks like kdm tries to access some of 
the scripts we're providing there.

I'll add a requirement in the next version.
Comment 9 Mike Chambers 2001-09-03 08:42:37 EDT
It was already installed on my machine.

[reddawg@goober reddawg]$ rpm -q XFree86-xdm
Comment 10 Joe Christy 2001-09-03 11:04:29 EDT
Bero - I don't understand your comment. XFree86-xdm was/is already installed on
my machine:
 [root@moby root]# rpm -q XFree86-xdm

Since my putative fix basically consisted of copying various files into
/usr/share/config/kdm which are owned by xinitrc and kdebase, I don't see what
XFree86-xdm has to do with it. - Joe
Comment 11 Bernhard Rosenkraenzer 2001-09-03 11:07:57 EDT
Does this still happen if you rpm -e --nodeps kdebase and reinstall it (using 
the updated package), the way the changelog suggests?
We did break updating from the beta to the final (intentional change, the 
problem was in the old (beta) package).

Comment 12 Bernhard Rosenkraenzer 2001-09-03 11:11:26 EDT
(The XFree86-xdm comment was simply because that's another thing that can 
break kdm)
Comment 13 Joe Christy 2001-09-03 11:55:52 EDT
The first "rpm -e --nodeps kdebase;rpm -ivh kdebase" failed when cpio tried to
replace an old directory [whose name was lost on reboot] with a file; rm -rf'ing
the directory and repeating the rpm -ivh did indeed solve the problems.

I didn't even know there was a changelog to suggest removing and re-installing
kdebase. Where would I look for such a thing?

Thanks, Bero!
Comment 14 Mike Chambers 2001-09-03 12:23:29 EDT
Worked here for me too.  Although doing up2date from the beta site I don't see 
a way to download anything manually, so hard to do a changelog on something to 
konw what is up.  But the newer package seems to work.

Although the Login Manager doesn't keep the settings as far as the background 
colors at the KDE GUI login.  Keeps referring back to default blue instead of 
what I changed it to.  That related to this at all or what do I file it under?
Comment 15 Bernhard Rosenkraenzer 2001-09-04 10:29:47 EDT
(Caused by breakage in versions prior to 2.2-6)

Note You need to log in before you can comment on or make changes to this bug.