Bug 529954 - virt-manager dialog buttons do not follow the HIG
virt-manager dialog buttons do not follow the HIG
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F13VirtTarget
  Show dependency treegraph
 
Reported: 2009-10-20 17:34 EDT by Michael Monreal
Modified: 2010-01-04 15:03 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-04 15:03:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (22.47 KB, image/png)
2009-10-20 17:34 EDT, Michael Monreal
no flags Details

  None (edit)
Description Michael Monreal 2009-10-20 17:34:16 EDT
Created attachment 365430 [details]
Screenshot

The buttons in most of virt-manager's windows and dialogs have a strange look and feel. This seems to be because the buttons are sized to fit their label. Other GTK apps and stock dialogs make the buttons slightly longer than what is actually needed to hold the label.

Also, the HIG¹ says:

"Do not use more than one or two different widths of button in the same window, and make all of them the same height. This will help give a pleasing uniform visual appearance to your window that makes it easier to use."

This rule is not honored, for example see the screenshot, which shows buttons in 56px, 43px and 63px sizes all in the same window. Compare their look with those from the file chooser shown below.

[1] http://library.gnome.org/devel/hig-book/stable/controls-buttons.html.en
Comment 1 Cole Robinson 2009-10-21 08:36:29 EDT
Thanks for the report, this was actually fixed upstream a few weeks ago:

http://hg.fedorahosted.org/hg/virt-manager/rev/292a065aad7e
Comment 2 Mark McLoughlin 2009-10-29 12:21:56 EDT
Adding to F13VirtTarget, no particular urgency about backporting to Fedora 12
Comment 3 Bug Zapper 2009-11-16 08:55:52 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Fedora Update System 2009-12-03 18:47:34 EST
virt-manager-0.8.1-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/virt-manager-0.8.1-1.fc12
Comment 5 Fedora Update System 2009-12-04 18:34:43 EST
virt-manager-0.8.1-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12603
Comment 6 Cole Robinson 2010-01-04 15:03:40 EST
Fixed in virt-manager-0.8.2-1.fc12, now in stable.

Note You need to log in before you can comment on or make changes to this bug.