Bug 529957 - Error when correcting search permissions
Error when correcting search permissions
Status: CLOSED DUPLICATE of bug 530210
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-20 17:49 EDT by Michael Monreal
Modified: 2009-10-29 13:21 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-29 13:15:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot 1 (78.78 KB, image/png)
2009-10-20 17:49 EDT, Michael Monreal
no flags Details
Screenshot 2 (60.18 KB, image/png)
2009-10-20 17:50 EDT, Michael Monreal
no flags Details

  None (edit)
Description Michael Monreal 2009-10-20 17:49:56 EDT
Created attachment 365433 [details]
Screenshot 1

I got a strange error when creating a new VM from an ISO image I had in my home directoy. virt-manager told me that the emulator may not have the permissions to access the file here and offered to correct it (screenshot 1). I pressed ok and got another window which told me that changing the permissions on my home folder is not supported (screenshot 2). I noticed that the ISO image itself was no longer owned by my user though, and that I needed root permissions to change this again.

I think that the first window should explain better who needs which permissions and what virt-manager actually has to change. I ended up moving the ISO image to /iso because changing ACLs inside my home didn't seem like a great idea.
Comment 1 Michael Monreal 2009-10-20 17:50:24 EDT
Created attachment 365434 [details]
Screenshot 2
Comment 2 Mark McLoughlin 2009-10-29 12:20:18 EDT
Michael: could you attach ~/.virt-manager/virt-manager.log

First thing we need to do is figure out why the setfacl failed - is your homedir NFS mounted?
Comment 3 Michael Monreal 2009-10-29 12:59:05 EDT
I am currently updating to the latest *virt* and qemu* packages and will try again with those. All I can say right now is that my home is not on NFS (it is ext3)
Comment 4 Mark McLoughlin 2009-10-29 13:07:48 EDT
If you do 

  $> tune2fs -l $dev  | grep 'mount options'

on the device which /home is mounted, is it missing the 'acl' option?

If so, then it's a dup of bug #530210
Comment 5 Michael Monreal 2009-10-29 13:15:04 EDT
(In reply to comment #4)
> If so, then it's a dup of bug #530210  

Indeed:

Default mount options:    (none)

Technically the other bug is the dupe but it has more useful information, so... CLOSED=>DUPLICATE

*** This bug has been marked as a duplicate of bug 530210 ***
Comment 6 Mark McLoughlin 2009-10-29 13:21:08 EDT
Thanks for confirming Michael

Note You need to log in before you can comment on or make changes to this bug.