Bug 52998 - stp driver not working
stp driver not working
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: printtool (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-01 11:17 EDT by Inger Karin Haarbye
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-13 11:25:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Inger Karin Haarbye 2001-09-01 11:17:19 EDT
Description of Problem:

I usually don't use printtool, I use CUPS and gimp-print. This is because
my Epson Stylus Color 880 is very well supported by CUPS/Gimp-print, and
CUPS is easy to use (and configure) with the varios possible settings with
this driver.
Today - with Fairfax RC2 - I would give printtool a try again. My usb
printer was detected, and I found my printer - it was set up with
stp-driver. (and lpd restarted...) 
It doesn't work however - if I try printing I get (repeatedly) on my
printer: 
"**** Unable to open the initial device, quitting". 

Trying to "edit" my new printer-settings (dpi, colors) does not work, the 
edit-box just vanish.

I have tried with paralell-port as well, same result.

Then I tried with a different driver, stc740 driver works for this printer
(but the results are not so nice). So I assume the problem must be related
to the stp driver.

Version-Release number of selected component (if applicable):

printconf-0.3.36-1
printconf-gui-0.3.36-1

How Reproducible:

always

Steps to Reproduce:
1. printtool (or printconf-gui), selecting local printer (lp) -> 	 
/dev/usb/lp0 -> Epson -> Stylus Color 880 -> stp.
 
2. save settings (restarting lpd) -> print test. 
3. trying to edit printer-driver-settings.

Actual Results:

1)
**** Unable to open the initial device, quitting
- is repeatedly printed out.

2) 
when trying to edit printer-driver settings the box just vanishes.

Expected Results:

1) A "normal" outprint, at least for text.
2) To be able to edit printer-settings


Additional Information:

1)Printing directly to the device works (cat /etc/fstab > /dev/usb/lp0).
2)Using a different driver works as expected. (stc740).
3)No difference paralell-port/usb-port.
Comment 1 Inger Karin Haarbye 2001-09-13 07:14:23 EDT
The problem is still there in Enigma. Epson Stylus Color 880 is not working 
with the suggested driver (stp).
Comment 2 Ray Curtis 2001-09-13 11:25:47 EDT
Yes, I also see this with the Epson 880 and stp.
The strange thing is that it works fine or as well as
expected from the stp driver with RedHat 7.1 for me.
The printcap files on both 7.1 & 7.2 are the same.
This is actually on Enigma not RC2.

I just see the line:
**** Unable to open the initial device, quitting.

Just wanted to add my input also.
Comment 3 Crutcher Dunnavant 2001-11-26 11:51:15 EST
Apply the updates, then perform:

rm -rf /var/cache/foomatic/compiled/* /var/cache/foomatic/pcache/*
/usr/sbin/printconf-backend --force-rebuild

this should fix it.

There was a typo in one of the updates, which didn't clear the cache.

Note You need to log in before you can comment on or make changes to this bug.