Bug 53008 - up2date crashes: Invalid Server Certificate.
up2date crashes: Invalid Server Certificate.
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
Depends On:
  Show dependency treegraph
Reported: 2001-09-01 14:29 EDT by Damian Christey
Modified: 2015-01-07 18:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-10-04 11:37:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Damian Christey 2001-09-01 14:29:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:0.9.3+) Gecko/20010830

Description of problem:
Following registration with rhn, up2date crashes on start everytime I run
it.  Error is only visible if run from command line.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run up2date and register with rhn if not already registered.
2. run up2date again from a terminal

Actual Results:  [root@Base rhn]# up2date      
Xlib: connection to ":0.0" refused by server
Xlib: Client is not authorized to connect to Server
Xlib: connection to ":0.0" refused by server
Xlib: Client is not authorized to connect to Server

For this beta release of Red Hat Linux, the up2date program has been
configured to point to a different Red Hat Network server.  This server
(beta.rhns.redhat.com) can be used to obtain updated packages for the
duration of this Red Hat Linux beta test ONLY.  After the beta test has been
completed, this Red Hat Network server will no longer be available for use.

Traceback (innermost last):
  File "/usr/sbin/up2date", line 1017, in ?
  File "/usr/sbin/up2date", line 348, in main
    raise f 
xmlrpclib.Fault: <Fault -9 """
Error Class Code: 9
Error Class Info: Invalid Server Certificate.
     An error has occured while processing your request. If this problem  
  persists please submit a bug report to rhn-help@redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what were you trying to do when this error occured and
     details on how to reproduce this problem.
[root@Base rhn]# 

Expected Results:  Program should run.

Additional info:

This is a fresh install of the beta on a new hardrive.
I may have mucked something up the first time I registered with rhn.  My
old system profile was still entitled in my account.  I removed it and then
reinstalled the up2date package, and registered again.
Comment 1 Jay Turner 2001-09-04 09:23:42 EDT
One of two things is happening.  Either your machine is registered with the beta
site (as it should be) and up2date is still talking to the live site, or your
machine is registered with the live site and up2date is talking to the beta site.

Check out the /etc/sysconfig/rhn/rhn_register config file and make sure that
serverURL is set to 'https://beta.rhns.redhat.com/XMLRPC'  Then check the
/etc/sysconfig/rhn/up2date config file and make sure that serverURL is pointing
to 'https://beta.rhns.redhat.com/XMLRPC'  If you have to make a change in the
rhn_register file, then you will need to rerun rhn_register and register your
machine again.  If you made the change in the up2date config file, then you
should be good to go.
Comment 2 Damian Christey 2001-09-04 12:02:20 EDT
serverURL was correct in the up2date conf file, but not in rhn_register.
Corected, reregistered, and it seems to work.  Thanks for the tip!
Comment 3 Adrian Likins 2001-09-04 12:33:13 EDT
also, there is another bug pointed out by this post. Namely that the
invalid certificate error was being show in a gui dialog when runing
the client in gui mode. This is a bug. This will be fixed in the
next version.
Comment 4 Robin Norwood 2001-10-04 09:55:22 EDT
I get a very similar error - I do not get the Xlib: lines, but everything after
the dialog box popup I do get (I am running X at the time - haven't tried it
outside of X).  Everything after the dialog box is identical to what nu11i7y
reports.  I checked the files listed (rhn_register and up2date), and both of the
serverURL's were correct - running rhn_register gets the question: 'This system
appears to already be registered.  Continue anyway?  I have not yet re-run the
registration, and www.redhat.com/network seems to be down right now.

P.S. - Hi Chip!
Comment 5 Chip Turner 2001-10-04 11:37:52 EDT
User error.  He rhn_register'd with 7.1 and then upgraded to roswell and didn't
re-rhn_register to the beta servers.

Note You need to log in before you can comment on or make changes to this bug.