Bug 53010 - shutdown errors with NFS-mounted /usr
shutdown errors with NFS-mounted /usr
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-01 14:38 EDT by Michael Redinger
Modified: 2014-03-16 22:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-29 15:09:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2001-09-01 14:38:36 EDT
In rc2 (and previous betas AFAIK - didn't have the time to have a closer
look at this), there are error messages when /usr is (read-only) on an
NFS server.
On shutdown, the following messages are printed (including the messages
before and after the errors):

Stopping crond:                                               [   OK   ]
Unmounting NFS filesystems:  umount2: Invalid argument
umount: /usr not mounted
                                                              [ FAILED ]
/etc/rc.d/rc:  line 125:  1616 Killed                    $i stop
Saving random seed:                                           [   OK   ]
...
Shutting down system logger:                                  [   OK   ]
Unmounting NFS filesystems:                                   [   OK   ]
/etc/rc.d/rc: line 125:  1748 Killed                     $i stop
Flushing all chains:                                          [   OK   ]
...
Resetting built-in chains to the default ACCEPT policy:       [   OK   ]
Starting killall: /etc/rc.d/rc: line 4: 1876 Killed
    initlog $INITLOG_ARGS -c "$*"
                                                              [ FAILED ]
Sending all processes the TERM signal ...                     [   OK   ]
...
Unmounting file systems                                       [   OK   ]


umount says, /usr is no longer mounted. I checked this, umount is
lying here ... :)

The first "[process] killed" comes from
/bin/bash /etc/rc6.d/K75netfs stop

The second "[process] killed" is
/bin/bash /etc/rc6.d/K90network setop

The third one is
initlog -q - /etc/rc6.d/S00killall start

I did try a fuser -m -v /usr right after these messages.
The first fuser (netfs) says, that K75netfs is using /usr (because
fuser is running from this script???).
The second one (network) says, that K90network and netfs are still using
/usr.
The third one (in killall) says that initlog and S00killall are using /usr.

I did a cat /proc/mount before and after each of these messages.
/usr keeps being mounted.
Comment 1 Michael Redinger 2001-09-19 06:50:51 EDT
The problem still exists in the final release.
Comment 2 Michael Redinger 2002-03-24 10:15:10 EST
The problem still exists in Hampton beta3.
Comment 3 Bill Nottingham 2005-09-29 15:09:19 EDT
Closing bugs on older, no longer supported, releases. Apologies for any lack of
response.

If this persists on a current release, such as Fedora Core 4, please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.