Bug 530137 - Fedora::Bugzilla - $bug->blocks_bug() fail
Summary: Fedora::Bugzilla - $bug->blocks_bug() fail
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Fedora-Bugzilla
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Chris Weyl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-21 16:49 UTC by Jiri Pirko
Modified: 2015-05-05 01:18 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-06-28 15:04:48 UTC
Type: ---


Attachments (Terms of Use)
test script (553 bytes, application/x-perl)
2009-10-21 16:49 UTC, Jiri Pirko
no flags Details

Description Jiri Pirko 2009-10-21 16:49:09 UTC
Created attachment 365567 [details]
test script

Description of problem:
When I try to get bugs that bz depends on, it fails in a way below and returns only one bz "0".

Version-Release number of selected component (if applicable):

0.10-1 - I tried 0.13 from CPAN and problem is still there.

How reproducible:
Always

Steps to Reproduce:
run attached script
  
Actual results:
blocks_bug
Use of uninitialized value $_[1] in exists at /usr/lib/perl5/vendor_perl/5.10.0/MooseX/AttributeHelpers/MethodProvider/ImmutableHash.pm line 10.
0
all_blocked_bugs

Expected results:
blocks_bug
499884
all_blocked_bugs

Comment 1 Jiri Pirko 2009-10-21 17:02:43 UTC
Well all_blocked_bugs() returns bzs listed in "Blocks" field. This suggest following:

"Depends on" *eq* blocks_bug()
"Blocks" *eq* all_blocked_bugs()

That doesn't sound good to me. Thoughts?

Comment 2 Chris Weyl 2009-10-22 05:44:42 UTC
Yeah...  Not good :)

I've updated the blocks/depends atts and added tests to validate it.  I haven't pushed it to the CPAN as 0.14 yet as I have some additional work to square away with the alias bits, but it is out on github... As well as documentation to write :)

Comment 3 Jiri Pirko 2009-10-22 06:56:35 UTC
Hmm, Can you please provide me your testing pre-0.14 package for testing? Or do you plan to update cpan to 0.14 any time soon? My script is kinda stuck atm :(

Comment 4 Chris Weyl 2009-10-22 14:55:10 UTC
No problem:

  http://github.com/RsrchBoy/fedora-bugzilla

I do plan on releasing 0.14 soon...  I'm hoping later this week I should have a few tuits free to do just that.

Comment 5 Jiri Pirko 2009-10-22 15:28:27 UTC
(In reply to comment #4)
> No problem:
> 
>   http://github.com/RsrchBoy/fedora-bugzilla

Just tried this and issue described in this bz still occurs :( - no change so far...

> 
> I do plan on releasing 0.14 soon...  I'm hoping later this week I should have a
> few tuits free to do just that.

Comment 6 Chris Weyl 2009-10-22 19:46:13 UTC
Hmm.  Can you try running the tests in t/09.depends-blocks.t?  They all pass for me, finding depends/blocks correctly.

Comment 7 Jiri Pirko 2009-10-22 21:50:12 UTC
Well, it seems t/09.depends-blocks.t works fine:

ok 1 - The object isa Fedora::Bugzilla::Bug
ok 2 - bug depends on other bugs
ok 3 - bug depends on 3 other bugs
ok 4 - bug depends on 476141
ok 5 - bug depends on 476143
ok 6 - bug depends on 476155
ok 7 - bug blocks other bugs
ok 8 - bug blocks 2 other bugs
ok 9 - bug blocks 478571
ok 10 - bug blocks 478572
1..10

I'll investigate this more tomorrow

Comment 8 Jiri Pirko 2009-10-23 07:48:25 UTC
Right, so I figured out what's wrong. In bztest3.pl script I'm using blocks_bug() in a wrong way.

To get a list of dependent bugs and blocks bugs I'm using successfully following:

print "all_dependent_bug_ids\n";
@dependent_bugs = $bug->all_dependent_bug_ids;
foreach (@dependent_bugs){
        print "$_\n";
}

print "all_blocked_bug_ids\n";
@blocked_bugs = $bug->all_blocked_bug_ids;
foreach (@blocked_bugs){
        print "$_\n";
}

I would suggest you to add test for these 2 to t/09.depends-blocks.t

Thanks.

Comment 9 Bug Zapper 2010-04-28 10:54:28 UTC
This message is a reminder that Fedora 11 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 11.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '11'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 11's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 11 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 10 Bug Zapper 2010-06-28 15:04:48 UTC
Fedora 11 changed to end-of-life (EOL) status on 2010-06-25. Fedora 11 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.