This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 530178 - virt-manager right-click menu for connections should have a delete item
virt-manager right-click menu for connections should have a delete item
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12VirtTarget
  Show dependency treegraph
 
Reported: 2009-10-21 15:42 EDT by Gianluca Cecchi
Modified: 2009-12-03 18:50 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-03 18:50:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gianluca Cecchi 2009-10-21 15:42:23 EDT
Description of problem:
you create a connection and then you want to delete it.
Because you created it wrong or for other reasons

Version-Release number of selected component (if applicable):
F11 + rawvirt repo
virt-manager-0.8.0-7.fc11.noarch

How reproducible:
Always

Steps to Reproduce:
1. create a fake connection or a real one
2. try to remove it
3. select connection and right click it
  
Actual results:
you cannot find a way of deleting it

Expected results:
delete option between the available ones

Additional info:

Actually you can delete it this way:
- select connection
- from the top menu select edit
- select delete

But I think it would more intuitive and natural to have it in right click context menu too
Comment 1 Mark McLoughlin 2009-10-29 12:45:09 EDT
Yeah, I've noticed this too. Thanks for the report
Comment 2 Paul Jenner 2009-11-12 15:29:44 EST
There was a similar bug recently closed for adding Delete to right-click context menu for virtual machines - bug #498461.

I think there may be a few places where the actions available from right-click context menu do not match the actions available from select and edit menu (or toolbar buttons for that matter) that I have noticed as a user in the past. If I identify any before this is closed, I will add them here.
Comment 3 Paul Jenner 2009-11-12 15:32:10 EST
Sorry typo - last comment should have referenced bug #498641.
Comment 4 Cole Robinson 2009-11-16 16:37:13 EST
Fixed upstream:

http://hg.fedorahosted.org/hg/virt-manager/rev/3b9d502cada4

Paul, I'll audit the available context menu options and make sure they match up with the Menu options before the next release (soon now).
Comment 5 Cole Robinson 2009-12-03 18:50:22 EST
This should be fixed in virt-manager-0.8.1-1.fc13 which will be in the next rawhide compose.

Note You need to log in before you can comment on or make changes to this bug.