Bug 53019 - Question about converting line feeds is (probably) incorrectly formatted
Question about converting line feeds is (probably) incorrectly formatted
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-01 17:45 EDT by Göran Uddeborg
Modified: 2007-04-18 12:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-10 11:26:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2001-09-01 17:45:30 EDT
In the message catalog for printconf there is a message

#. ../gui/printconf-gui.glade:1570 ../gui/printconf-gui.glade:3545
#: ../gui/printconf-gui.glade.str:243
msgid ""
"Translate \n"
" => \r\n"
msgstr ""
"Vversdtt \n"
" => \r\n"

(I'm using the Swedish translation for illustration, but that's not
important.)  This first makes sense when looking at it in the message
catalog file.  But these strings are interpreted as in C code, so the \n
and \r will be translated to the corresponding control characters.  That's
probably not intended.  There is another message in the same file:

#: ../util/printconf_tui.py:1205
msgid "Translate \\n->\\r\\n"
msgstr "Vversdtt \\n->\\r\\n"

I believe the first message should have looked this way too.

Disclaimer:  I can't install and verify this on any machine right now.  But
since this might be urgent, with the lead time necessary for translations,
I didn't want to delay reporting it until I could verify it.  I apologise
if my assumptions are wrong and this report is incorrect.
Comment 1 Tim Waugh 2002-01-10 11:26:23 EST
Yes, that does look wrong.
Comment 2 Tim Waugh 2002-03-06 08:43:10 EST
All occurrances of this are now fixed.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.