Bug 530220 - kppp Not Able to Initialize Modem in Fedora 12 Beta
Summary: kppp Not Able to Initialize Modem in Fedora 12 Beta
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kdenetwork
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Than Ngo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 519515
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-21 22:19 UTC by David Le Sage
Modified: 2009-10-25 15:25 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-25 15:25:45 UTC
Type: ---


Attachments (Terms of Use)

Description David Le Sage 2009-10-21 22:19:59 UTC
Description of problem:
Note that this is a show-stopper bug for anyone who needs to use a dial-up modem to connect to the internet.  


When kppp is launched to dial-up with a generic USB modem on /dev/ttyusb0 it will freeze at the point at which it tries to "initialise."


kppp has worked with this modem on all previous Fedora releases. No configuration settings have been altered.



Version-Release number of selected component (if applicable):
KDE 4.3/kppp (Fedora 12 Beta.)

How reproducible:
Every time.

Steps to Reproduce:
1. Connect an external USB modem to /dev/ttyusb0
2. Configure kppp so that it dials into an ISP using this modem.
3. Launch kppp.  It will freeze as soon as it reaches the "initialize" stage.
  
Actual results:
Cannot initialize.

Expected results:
Dial in and connect to ISP.

Additional info:
When I was looking at the alpha release, I had another problem that you may wish to look at:  


https://bugzilla.redhat.com/show_bug.cgi?id=519515


I attached my dmesg log to that earlier bug, which contains some information about the modem.

Comment 1 Kevin Kofler 2009-10-22 00:48:03 UTC
Are you sure this is a Kppp issue? Have you tried it in F11 + current updates, which has almost the same KDE (F11 stable updates: 4.3.1, F11 updates-testing and F12 Beta: 4.3.2)?

Comment 2 David Le Sage 2009-10-22 00:54:08 UTC
Kevin, thanks for responding.  It definitely works in the "base" Fedora 11.  Due to the fact that this home machine is using dial-up networking, it is not practical to download all of the updates from the yum repo.  


I did do an interim update about eight weeks ago, though, by putting most of the RPM updates on a DVD and installing these.  Again, no problem with kppp in this case.

Comment 3 Kevin Kofler 2009-10-22 01:27:37 UTC
Do you remember what KDE you picked up back then? 4.3.0? Or 4.2.4?

Comment 4 David Le Sage 2009-10-22 01:33:06 UTC
No, sorry, I can't.  Might be able to find the disk containing the updates when I go home tonight.

Comment 5 David Le Sage 2009-10-22 21:57:33 UTC
Hello Kevin,



I did some fairly extensive further investigation last night.  The good news, from your perspective, is that it is not a kppp problem, so you can close this ticket.  


It is related to this earlier problem I had, whereby the modem is locking up during the boot process:  https://bugzilla.redhat.com/show_bug.cgi?id=519515

hence the reason I cannot go past the "initialize" stage when I run kppp.  If I unplug the modem when booting and only plug it back in when I am prepared to use it, kppp works without a problem.  I'll chase up the  issue on the other ticket, so feel free to close this one.


Cheers,


David


Note You need to log in before you can comment on or make changes to this bug.