Bug 53026 - sndconfig nm256_audio core dumps
Summary: sndconfig nm256_audio core dumps
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sndconfig   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-02 02:47 UTC by HP
Modified: 2014-03-17 02:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-21 22:18:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description HP 2001-09-02 02:47:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)

Description of problem:
sndconfig core dumps after playing sound.  I have Sony VAIO Laptop with 
192MB RAM and 2.5MB shared audio/video NeoMagic 256AV.
I previously had Red Hat Linux 6.2 on my system and the sndconfig utility 
worked fine with my sound card.
Currently I have a fresh installation of RHL 7.1.  When I tried sndconfig 
it detects the NeoMagic 256AV sound card.  But when it goes to play the 
sample sound all I hear is chirping sounds and then it core dumps.  When I 
tried sndconfig again I got the same chirping sound but the program did 
not core dump, but I still could not use the sound card.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run 'sndconfig'
2. Let it detect the NeoMagic 256AV sound card
3. Then when it tries to play the sample sound you will hear chirping 
noise.
4. Then the utility core dumps (on the first try), or goes back to the 
command prompt and the sound card is still not usable.
	

Actual Results:  sound card was not usable.

Expected Results:  usable sound card

Additional info:

This sound card was working with RHL 6.2 and 7.0 system.  I removed the 
previous RHL system and performed a clean installation.

Comment 1 HP 2001-09-03 20:31:05 UTC
I found a way of getting the sound card to work by bypassing the sndconfig.

Instead of using sndconfig which core dumps and writes the following:
alias sound-slot-0 nm256_audio
post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 
2>&1 || :
pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 
|| :

to the /etc/modules.conf file.

I commented out those lines and added the following line:
alias sound nm256_audio

(To the developers of sndconfig)
If you need further information in why sndconfig causes segmentation fault, let 
me know which files you need and I will upload them.

Comment 2 HP 2001-09-04 02:06:09 UTC
Spoke too soon, all I get now is chirping sounds.

Comment 3 Bill Nottingham 2002-01-25 04:01:48 UTC
Does this continue, even with the errata kernel? Are there any errors in
/var/log/messages?

Comment 4 Bill Nottingham 2005-01-21 22:18:29 UTC
sndconfig is no longer developed, and this release has reached end-of-life.
Closing out old bugs.


Note You need to log in before you can comment on or make changes to this bug.