Bug 530278 - Anaconda fails with Spanish (Peru)
Anaconda fails with Spanish (Peru)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-22 02:23 EDT by Oliver Etchebarne
Modified: 2010-02-28 09:47 EST (History)
2 users (show)

See Also:
Fixed In Version: cups-1.4.2-31.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-22 08:10:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Oliver Etchebarne 2009-10-22 02:23:39 EDT
Description of problem:
If I choose as my language Spanish(Peru), anaconda fails with:

---

[liveuser@localhost ~]$ /usr/bin/liveinst 
umount: /media/*: no se ha encontrado
  0 logical volume(s) in volume group "vg_dorothy" now active
Traceback (most recent call last):
  File "/usr/sbin/anaconda", line 878, in <module>
    anaconda.id = instClass.installDataClass(anaconda, extraModules, opts.display_mode, anaconda.backend)
  File "/usr/lib/anaconda/instdata.py", line 302, in __init__
    self.reset()
  File "/usr/lib/anaconda/instdata.py", line 68, in reset
    self.timezone.setTimezoneInfo(self.instLanguage.getDefaultTimeZone())
  File "/usr/lib/anaconda/language.py", line 218, in getDefaultTimeZone
    return self.localeInfo[self.systemLang][4]
KeyError: 'es_PE.UTF-8'

---

As root, it seems to work ok.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Choose Spanish(Peru) at login screen.
2. Double clic on "Install on hard drive" ("Instalar en el Disco Duro") desktop icon, or run /usr/bin/liveinst on a console.
3.
  
Actual results:


Expected results:


Additional info:
I already have Fedora 11 installed on my hard disk ( LVM group "vg_dorothy" ).
Comment 1 Chris Lumens 2009-10-22 08:10:24 EDT

*** This bug has been marked as a duplicate of bug 528317 ***
Comment 2 Fedora Update System 2010-02-23 07:52:35 EST
cups-1.4.2-31.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/cups-1.4.2-31.fc13
Comment 3 Fedora Update System 2010-02-28 09:47:05 EST
cups-1.4.2-31.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.