Bug 53037 - dhcpcd failed to obtain an IP address, after up2date in a 8139too
dhcpcd failed to obtain an IP address, after up2date in a 8139too
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: dhcpcd (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-02 10:26 EDT by Alejandro Gonzalez Hernandez - Imoq
Modified: 2007-04-18 12:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-14 00:22:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/dmesg (7.30 KB, text/plain)
2001-09-02 10:28 EDT, Alejandro Gonzalez Hernandez - Imoq
no flags Details
lsmod (849 bytes, text/plain)
2001-09-02 10:29 EDT, Alejandro Gonzalez Hernandez - Imoq
no flags Details
/etc/modules.conf (297 bytes, text/plain)
2001-09-02 10:29 EDT, Alejandro Gonzalez Hernandez - Imoq
no flags Details
rpm -qa (11.91 KB, text/plain)
2001-09-02 10:30 EDT, Alejandro Gonzalez Hernandez - Imoq
no flags Details
ls -l /var/spool/up2date , just in case (39.77 KB, text/plain)
2001-09-02 10:30 EDT, Alejandro Gonzalez Hernandez - Imoq
no flags Details

  None (edit)
Description Alejandro Gonzalez Hernandez - Imoq 2001-09-02 10:26:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
I installed a fresh copy of roswell 2 from CDs, everything worked as 
expected. After I did an up2date -u (and downloaded 300+ MB of updates, 
geee!), rebooted because I installed the new kernel and then my network 
failed to start.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install roswell 2 from CDs.
2. up2date -u, wait until all 300+ MB are downloaded
3. reboot so the new kernel loads.
	

Actual Results:  Network fails to start.

Expected Results:  Be using mozilla under linux instead of IE under win :P


Additional info:

I'll paste several logs and files to see if you can think about a problem 
there... I didn't modify any config after the up2date, just rebooted and I 
swear I was connected with that NIC to download the files. BTW, my 
connection is via cablemodem, with a 3Com NIC (10/100) for the local 
network and a 8139too (10) for the internet.
Comment 1 Alejandro Gonzalez Hernandez - Imoq 2001-09-02 10:28:13 EDT
Created attachment 30600 [details]
/var/log/dmesg
Comment 2 Alejandro Gonzalez Hernandez - Imoq 2001-09-02 10:29:21 EDT
Created attachment 30601 [details]
lsmod
Comment 3 Alejandro Gonzalez Hernandez - Imoq 2001-09-02 10:29:47 EDT
Created attachment 30602 [details]
/etc/modules.conf
Comment 4 Alejandro Gonzalez Hernandez - Imoq 2001-09-02 10:30:14 EDT
Created attachment 30603 [details]
rpm -qa
Comment 5 Alejandro Gonzalez Hernandez - Imoq 2001-09-02 10:30:49 EDT
Created attachment 30604 [details]
ls -l /var/spool/up2date , just in case
Comment 6 Alejandro Gonzalez Hernandez - Imoq 2001-09-02 10:32:34 EDT
I forgot to mention:

I tried to rpm -Uvh pump, same results. After that, I just rpm -e pump (I never 
liked, anyway).

Here is some relevant stuff from /var/log/messages:

Sep  2 08:57:13 home network: Setting network parameters:  succeeded
Sep  2 08:57:14 home network: Bringing up interface lo:  succeeded
Sep  2 08:57:14 home ifup: Determining IP information for eth0...
Sep  2 08:57:28 home dhcpcd[1572]: terminating on signal 2 
Sep  2 08:57:31 home sysctl: net.ipv4.ip_forward = 0
Sep  2 08:57:31 home network: Disabling IPv4 packet forwarding:  succeeded
Sep  2 08:58:22 home sysctl: net.ipv4.ip_forward = 1
Sep  2 08:58:22 home sysctl: net.ipv4.conf.default.rp_filter = 1
Sep  2 08:58:22 home sysctl: kernel.sysrq = 0
Sep  2 08:58:22 home network: Setting network parameters:  succeeded
Sep  2 08:58:22 home network: Bringing up interface lo:  succeeded
Sep  2 08:58:22 home ifup: Determining IP information for eth0...
Sep  2 09:00:22 home dhcpcd[1846]: timed out waiting for a valid DHCP server 
response 
Sep  2 09:00:22 home ifup:  failed.
Sep  2 09:00:22 home network: Bringing up interface eth0:  failed
Sep  2 09:00:23 home kernel: eth1: Setting 100mbps full-duplex based on auto-
negotiated partner ability 41e1.
Sep  2 09:00:25 home network: Bringing up interface eth1:  succeeded
Sep  2 09:03:30 home kernel: Attached scsi CD-ROM sr0 at scsi0, channel 0, id 
0, lun 0
Sep  2 09:03:32 home kernel: sr0: scsi3-mmc drive: 32x/32x writer cd/rw 
xa/form2 cdda tray
Sep  2 09:06:22 home login(pam_unix)[1138]: session opened for user root by 
LOGIN(uid=0)
Sep  2 09:06:22 home  -- root[1138]: ROOT LOGIN ON tty2
Sep  2 09:06:37 home dhcpcd[2029]: timed out waiting for a valid DHCP server 
response 
Sep  2 09:06:37 home pumpd[2082]: starting at (uptime 0 days, 0:14:57) Sun Sep  
2 09:06:37 2001  
Sep  2 09:09:02 home dhcpcd[2133]: terminating on signal 2 
Comment 7 Alejandro Gonzalez Hernandez - Imoq 2001-09-04 10:57:36 EDT
After trying a lot of different things, and almost gave up (I tried switch 
kernels, use older dhcp, etc.) I just figured one way to solve this, and it's 
very simple:

I just change /etc/modules.conf to

alias eth0 8139too
alias eth1 3c59x

and switched /etc/syconfig/network-scripts/ifcfg-eth0 with ifcfg-eth1, did a 
reboot (service network stop/start didn't work, it had the eth1 IP stick) and 
all worked.

Now, before rush and mark this as "NAB", I want you to remember something: The 
box WAS working, I did an up2date -u and then it stoped working... no changing 
cables, no changing NICs, not anything else, so, I think it might be an issue.

Anyway, not for me anymore ;).
Comment 8 Need Real Name 2001-10-10 20:21:50 EDT
I've got the exact same setup. Roswell, Dual Pentium SMP, 3Com 10/100 Nic,
Cablemodem.
DHCP works fine on my other 6.2 box.

Comment 9 Need Real Name 2001-10-11 12:28:06 EDT
I also loaded pump from the 7.1 RPM, and tried pump from a 6.2 distribution, on
the 7.1.99 Roswell
box. They both failed. (meaning, the problem may be deeper than just pump.)

Lemme know if you want an strace of the execution.
Comment 10 Elliot Lee 2002-01-04 13:02:52 EST
Apologies for the slow response - can anyone comment on this bug in relation to
7.2 or rawhide? (Does it still occur?)
Comment 11 Olivier Baudron 2002-01-05 19:24:31 EST
It's a bit confusing... 8139too is your interface to the internet and is aliased
to eth1 (at the beginning). So, why dhcpcd is used for eth0 and a static IP for
eth1?
Comment 12 Olivier Baudron 2002-01-06 05:59:33 EST
vaughanj, do you have one or two NICs?
Comment 13 Alejandro Gonzalez Hernandez - Imoq 2003-08-20 11:55:52 EDT
I think you should close this bug since that problem was solved LONG ago ;)

Note You need to log in before you can comment on or make changes to this bug.