Bug 530375 - Kernel Oops (Failure in the tiling code)
Kernel Oops (Failure in the tiling code)
Status: CLOSED DUPLICATE of bug 489907
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
card_945GM
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-22 10:53 EDT by Dave Russell
Modified: 2009-10-27 13:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 13:44:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
md5sum of the sosreport already attached (33 bytes, text/plain)
2009-10-22 11:37 EDT, Dave Russell
no flags Details

  None (edit)
Description Dave Russell 2009-10-22 10:53:20 EDT
Description of problem:
During the hotplug of a vga monitor and enabling of it a kernel oops is produced in the logs.

Version-Release number of selected component (if applicable):
xorg-x11-drv-intel-2.7.0-7.fc11.i586

How reproducible:
Every time

Steps to Reproduce:
1. Attach external monitor
2. Set external monitor to display
3. Kernel oops
  
Actual results:

Kernel oops

Expected results:

No kernel oops

Additional info:

The action does work, it's just the kernel oops that's not very comforting.
Comment 2 Dave Russell 2009-10-22 11:37:57 EDT
Created attachment 365745 [details]
md5sum of the sosreport already attached
Comment 3 Dave Russell 2009-10-22 11:38:41 EDT
Kernel oops as submitted to kerneloops.org

http://www.kerneloops.org/submitresult.php?number=833000
Comment 4 Matěj Cepl 2009-10-27 05:00:41 EDT
Created attachment 366219 [details]
dmesg_now from sosreport (attachment 365744 [details])
Comment 5 Matěj Cepl 2009-10-27 05:00:49 EDT
Created attachment 366220 [details]
lspci from sosreport (attachment 365744 [details])
Comment 6 Matěj Cepl 2009-10-27 05:00:56 EDT
Created attachment 366221 [details]
Xorg.0.log from sosreport (attachment 365744 [details])
Comment 7 Matěj Cepl 2009-10-27 13:41:08 EDT
[drm] DAC-6: set mode  23
[drm:i915_gem_object_unbind] *ERROR* Attempting to unbind pinned buffer
------------[ cut here ]------------
WARNING: at drivers/gpu/drm/i915/i915_gem_tiling.c:473 i915_gem_set_tiling+0x4a0/0x4f2 [i915]() (Not tainted)
Hardware name: 1951W7V
failed to unbind object for tiling switchModules linked in: ppp_deflate zlib_deflate ppp_async crc_ccitt ppp_generic slhc option usbserial fuse usb_storage rfcomm sco bridge stp llc bnep l2cap sunrpc ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 cpufreq_ondemand acpi_cpufreq dm_multipath uinput snd_hda_codec_analog snd_hda_intel arc4 snd_hda_codec ecb snd_hwdep iwl3945 snd_pcm snd_timer snd mac80211 e1000e iTCO_wdt thinkpad_acpi yenta_socket iTCO_vendor_support soundcore btusb hwmon i2c_i801 pcspkr rsrc_nonstatic lib80211 snd_page_alloc bluetooth cfg80211 joydev ata_generic pata_acpi xts gf128mul aes_i586 aes_generic dm_crypt i915 drm i2c_algo_bit i2c_core video output [last unloaded: microcode]
Pid: 1989, comm: Xorg Not tainted 2.6.29.6-217.2.3.fc11.i686.PAE #1
Call Trace:
 [<c0435266>] warn_slowpath+0x7c/0xa4
 [<c0562f99>] ? idr_remove+0x11a/0x128
 [<c0562f99>] ? idr_remove+0x11a/0x128
 [<c0714f0d>] ? printk+0x14/0x17
 [<f8216215>] ? i915_gem_object_unbind+0x43/0x1f3 [i915]
 [<f81bb551>] ? drm_gem_object_reference+0xd/0xf [drm]
 [<f821a4e4>] i915_gem_set_tiling+0x4a0/0x4f2 [i915]
 [<f81ba74b>] drm_ioctl+0x202/0x292 [drm]
 [<f821a044>] ? i915_gem_set_tiling+0x0/0x4f2 [i915]
 [<c04fb6f1>] ? ext4_file_write+0xb8/0x12f
 [<c04a8361>] ? do_sync_write+0xb0/0xeb
 [<c04b26be>] vfs_ioctl+0x5c/0x76
 [<c04b2f72>] do_vfs_ioctl+0x480/0x4ba
 [<c04a80b8>] ? fsnotify_modify+0x54/0x5f
 [<c04a82b1>] ? do_sync_write+0x0/0xeb
 [<c04a8c11>] ? vfs_write+0xb5/0xf4
 [<c046bd4f>] ? audit_syscall_entry+0x163/0x185
 [<c04b2ff2>] sys_ioctl+0x46/0x66
 [<c040945f>] sysenter_do_call+0x12/0x34
---[ end trace 6895ad0477d4c817 ]---
Comment 8 Matěj Cepl 2009-10-27 13:44:53 EDT

*** This bug has been marked as a duplicate of bug 489907 ***

Note You need to log in before you can comment on or make changes to this bug.