Bug 53038 - kbabel initial configuration fails in gnome.
kbabel initial configuration fails in gnome.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kdesdk (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-02 10:56 EDT by Eugene Kanter
Modified: 2007-04-18 12:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-28 15:41:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugene Kanter 2001-09-02 10:56:42 EDT
Description of Problem:

unable to start kbabel in gnome if it was never started for this user before.

Version-Release number of selected component (if applicable):

kdesdk-2.2-2

How Reproducible:

always

Steps to Reproduce:
1. create new user
2. start gnome
3. start kbabel from terminal or from "run" menu.


Actual Results:

big kbabel splash dialog box with no buttons to press and no decoration to
move the splash out of the way.

Expected Results:

a dialog with "OK" button should be displayed so user can continue initial
setup.

Additional Information:

When kbabel started in KDE, the dialog with "OK" button is displayed on TOP
of kbabel splash.
Comment 1 Havoc Pennington 2001-09-02 13:45:49 EDT
The splash screen is override redirect, which means the window manager
has no knowledge of it whatsoever, and can't let the user move it, and
can't guarantee anything about the stacking order with respect to
other windows. kbabel is purely in charge of that window and isn't
doing what's required to keep it in the right place. It only happens
to work under KDE for some not-guaranteed-by-the-ICCCM reason.

The splash screen should probably be a managed window with decorations
turned off (instead of override redirect), and that initial dialog
should
probably be set as transient of it.

Alternatively kbabel could implement some tricky code to keep the
splash below the dialog. (Keeping the dialog above the splash isn't
possible, because the WM is in charge of the dialog, kbabel only
controls stacking on the splash. So things have to be done in terms of
controlling the splash's position in Z order, not in terms of
controlling the dialog's position.)
Comment 2 Eugene Kanter 2001-09-02 13:54:14 EDT
As a workaround I suggest 
a) making the initial dialog big enough so it can be moved away from under the
splash and OK is pressed.
or
b) turn off the splash after a timeout of several seconds.
Comment 3 Ngo Than 2002-08-05 14:40:27 EDT
It's fixed in 3.0.2-3

Note You need to log in before you can comment on or make changes to this bug.