Bug 530428 - KeyError: <yuminstall.AnacondaYumRepo object at 0xb56edbec> during install in a VirtualBox instance
KeyError: <yuminstall.AnacondaYumRepo object at 0xb56edbec> during install in...
Status: CLOSED DUPLICATE of bug 505189
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:a2207071a0eab64c0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-22 14:53 EDT by Fredrik Rambris
Modified: 2010-02-02 09:47 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-26 10:00:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (794.76 KB, text/plain)
2009-10-22 14:53 EDT, Fredrik Rambris
no flags Details
Attached traceback automatically from anaconda. (1.32 MB, text/plain)
2009-10-25 05:42 EDT, Laurent Wandrebeck
no flags Details
Attached traceback automatically from anaconda. (1.29 MB, text/plain)
2010-02-02 09:47 EST, Matthias Clasen
no flags Details

  None (edit)
Description Fredrik Rambris 2009-10-22 14:53:03 EDT
The following was filed automatically by anaconda:
anaconda 12.37 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 234, in _sql_MD
    cache = getattr(self.sack, MD + 'db')[self.repo]
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 45, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.6/site-packages/yum/sqlitesack.py", line 269, in __getattr__
    (self.pkgId,)).fetchone()
  File "/usr/lib/python2.6/site-packages/yum/packages.py", line 576, in _size
    return self.packagesize
  File "/usr/lib/python2.6/site-packages/yum/packages.py", line 593, in <lambda>
    size = property(fget=lambda self: self._size())
  File "/usr/lib/python2.6/site-packages/yum/yumRepo.py", line 850, in getPackage
    size=package.size,
  File "/usr/lib/anaconda/yuminstall.py", line 172, in callback
    fn = repo.getPackage(po)
KeyError: <yuminstall.AnacondaYumRepo object at 0xb56edbec>
Comment 1 Fredrik Rambris 2009-10-22 14:53:11 EDT
Created attachment 365767 [details]
Attached traceback automatically from anaconda.
Comment 2 Laurent Wandrebeck 2009-10-25 05:42:14 EDT
Created attachment 366006 [details]
Attached traceback automatically from anaconda.
Comment 3 Chris Lumens 2009-10-26 10:00:29 EDT

*** This bug has been marked as a duplicate of bug 505189 ***
Comment 4 Matthias Clasen 2010-02-02 09:47:04 EST
Created attachment 388322 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.