Bug 53043 - RH 7.1 won't boot on IBM ThinkPad 1171 NM1 i-series laptops
RH 7.1 won't boot on IBM ThinkPad 1171 NM1 i-series laptops
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-09-02 11:35 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-11-11 14:08:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-09-02 11:35:28 EDT
Description of Problem:
I tried to install RH7.1 on my IBM ThinkPad 1171 NM1 i-series laptop and it wouldn't work.  When it got to loading /sbin/loader on the installer, it died.  It just stopped and the cursor kept flashing.  Only a reboot would let me do stuff with the computer.  I've talked to lots of people with this problem.  I have tried text mode with no success.  I tried RH6.2 and that worked fine.

How Reproducible:
Every time

Steps to Reproduce:
1. Boot off CD
2. Hit enter at menu choices
3. Watch

Actual Results:
Stops at 'loading /sbin/loader'

Expected Results:
Should load /sbin/loader and start the installer
Comment 1 Need Real Name 2001-09-04 00:07:40 EDT
I have the same problem. I boot from the CD Rom the installation runs thru and  
detects the type and speed of my CD Drive then fails to spawn /bin/sh because 
it can't find "exec". Then I get a few dozen messages saying that it can't read 
from hdc (the CD). I get the same error messages when I tried to install RH 7.0 
and Mandrake 8.0. I have no problems installing R.H 6.2 on the same system. 
I've tried to boot from a floppy using boot.img and oldcrrom.img but I still 
lose access to the CD drive during the install. I've also tried each 
installation method from the boot menu with the exact same result. I can't find 
any example of a harddrive install as this would be a last ditch attempt to get 
R.H 7.1 running.
Comment 2 Matt Wilson 2001-09-04 10:12:42 EDT
try booting with "linux ide=nodma" at the CD's boot: prompt
Comment 3 Need Real Name 2001-09-04 12:34:18 EDT
the linux ide=nodma command doesn't appear to work.  Seems to have the same problem.
Comment 4 Matt Wilson 2001-09-05 20:56:48 EDT
Can you see any errors on Alt+F3 or Alt+F4?
Comment 5 Brent Fox 2001-09-17 11:00:06 EDT
Any more info here?
Comment 6 Need Real Name 2001-09-18 11:20:07 EDT
It's too early in the boot process to get a F3 or F4 screen :(
Comment 7 Brent Fox 2001-09-18 15:38:36 EDT
I don't know, it sounds like either some sort of hardware problem or something
if you are seeing it with other distributions too.  It doesn't appear to be a
2.4 kernel issue since 7.0 doesn't work either and it was 2.2 kernel based.

Just as a guess, I'd say there's either something wrong with the cdrom drive or
the IDE controller.  Do you have another cdrom drive you could try with?
Comment 8 Need Real Name 2001-09-18 15:51:38 EDT
I haven't tried other distributions.  However, RedHat 6.2 worked fine.  I am
going to see if I can get ahold of a Mandrake 8 CD or something (anything based
on 2.4) and see if it dies.  If it does, I am going to sign up for
kernel-hackers and see what we can do there!
Unfortunatly, I don't have another CD-ROM to use.  If I could find a USB drive
or something like that, we'll try (oh yeah, that's going to work :).
I'll post my results of trying another distro.
Comment 9 Brent Fox 2001-09-19 10:12:54 EDT
Oh sorry.  I didn't see that the second post on this report wasn't the original
Comment 10 Brent Fox 2001-09-19 10:15:29 EDT
Do you have the bandwidth to download the Roswell public beta for the next
release and see if that perhaps fixes the problem?
Comment 11 Need Real Name 2001-09-19 12:55:06 EDT
I don't think the Roswell beta will help.  For followup sake, I do have the
bandwidth (I'm at Northern Michigan University right now).
I tried out a bunch of 2.4 based installs *RH ones and Mandrake) and they all
borked out.  I put in Debian Potato (2.2 based) and it worked fine.
Do you suggest to me that I sign onto kernel-hackers and notify them or what
should I do, since this appears to be kernel based.
Comment 12 Brent Fox 2001-09-19 14:33:01 EDT
Tell you what, I'll change the component of this bug to the kernel, that way our
kernel team can take a look at this.
Comment 13 Arjan van de Ven 2001-09-19 14:36:41 EDT
things to try:
type the following at the syslinux prompt:

"nomce apm=off nohlt ide=nodma"

Comment 14 Need Real Name 2001-09-20 08:12:03 EDT
I'll try that.  Note: I gotta get my disks back (I let a friend borrow them :)
so it maybe a day or so before I can post my hopefully successful results.  Just
letting you know.
Comment 15 Need Real Name 2001-09-20 11:27:29 EDT
I tried:
"linux nomce apm=off nohlt ide=nodma"
and it still didn't work.  What now?
Comment 16 Alan Cox 2001-09-20 15:52:54 EDT
At this point I'd say there are a limited number of possibilities, and pretty
much all of them are "broken bios consult vendor"

You can try booting with mem=32M in case the BIOS memory reporting is hosed.
The noapm option stops us trusting the bios for that.

The trouble is to debug a crash that early you need a serial port, a serial
console and some patience. If you have a serial port and something to log the
serial output to (eg another PC) I can lead you through that
Comment 17 Need Real Name 2001-09-20 16:08:30 EDT
Unfortunatly, there are no serial ports on this laptop (what I would do for a
stupid serial port though...sigh).  I am going to try:

linux mem=128M nomce apm=off nohlt ide=nodma

and see if that helps, but I'll buy ya lunch if that mem does work.  I'll buy
myself lunch if that mem works.  I doubt it will.  I am going to contact IBM
about this problem and make them put their money where their mouth is about
backing Linux.
Comment 18 Alan Cox 2001-09-20 16:11:49 EDT
Even if the box has 128Mb of RAM try mem=32M - thats a deliberate choice for an
initial test to eliminate shared video, acpi and other possible goings on
Comment 19 Need Real Name 2001-09-20 16:31:03 EDT
I did:

linux mem=32M nomce apm-off nohlt ide=nodma

When it's booting, it takes a while to get past the hard disk detecting part,
with the following error messages:

Partition check:
   hda: hda: lost interrupt
   hda1 hda 2 <hda: status error: status=0x58 { DriveReady SeekComplete DataRequest}
   hda: drive not ready for command

I pull the mem=32M line and it detects fine:

Partition check:
   hda: hda1 hda2 <hda5>

Does that give any clue about anything?
Comment 20 Need Real Name 2001-09-24 12:01:22 EDT
What happened to this bug?  I mean, it's still happening.  But are we giving up
or are there more things to try?  Should I subscribe to kernel hackers and
report the problem directly there?
Comment 21 Alan Cox 2001-09-24 12:12:47 EDT
The mem= shouldnt be affecting that behaviour unless this laptop is putting ACPI
stuff very very low in memory. If its doing that then I have no further ideas.

Posting it to l/k is worthwhile
Comment 22 Need Real Name 2001-10-05 12:51:45 EDT
I've done a little bit of work on this one.  I can get RedHat 6.2 on it.  I'm
just having a hard time with it saying my boot partition is too large.
Anyways, I updated my bios per Alan's request.  That didn't help anything.  Next
Comment 23 Need Real Name 2001-11-11 14:08:03 EST
This bug is not yet fixed.  I am not sure exactly what to do.  It doesn't work
in RedHat 7.2.
Comment 24 Need Real Name 2001-12-13 20:23:12 EST
HEY! This works.  I had to do a linux nousb on installer bootup (at least
installer, but I'm still waiting for it to finish install to see if I always
need nousb).  I'm happy now.

Note You need to log in before you can comment on or make changes to this bug.