Bug 530440 - (TabletPC) [Regression] Stylus not recognized on Tablet PC
[Regression] Stylus not recognized on Tablet PC
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: linuxwacom (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-10-22 15:57 EDT by Luya Tshimbalanga
Modified: 2009-10-29 12:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-29 12:58:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Xorg,log (26.95 KB, text/plain)
2009-10-23 02:32 EDT, Luya Tshimbalanga
no flags Details

  None (edit)
Description Luya Tshimbalanga 2009-10-22 15:57:36 EDT
Description of problem:
A case of regression after clean install from Fedora 11 Leonidas where stylus worked on LT20 Tablet PC. On Fedora 12 Beta release, that function no longer work. I am not if the issue is also related to the newest Xorg version.

Version-Release number of selected component (if applicable):
0.8.2.2-14

How reproducible:
Always 

Steps to Reproduce:
1. Start Fedora 12 Beta
2.
3.
  
Actual results:
No input from stylus

Expected results:
Stylus should work out of box

Additional info:
The hardware is a tablet CP LT-20
Comment 1 Luya Tshimbalanga 2009-10-22 16:01:35 EDT
After running xsetwacom, here is the result:

xsetwacom list dev
invalid escape %D found in path template
invalid escape %D found in path template
Unable to open config file
Comment 2 Luya Tshimbalanga 2009-10-22 20:07:42 EDT
I noticed upstream is updated to 0.8.4. Is it possible to update the package so I can see if that resolves the issue with TabletPC?
Comment 3 Peter Hutterer 2009-10-23 01:38:51 EDT
please attach your Xorg.log and (if applicable) your xorg.conf as well.
Comment 4 Luya Tshimbalanga 2009-10-23 02:32:56 EDT
Created attachment 365814 [details]
Xorg,log

Included Xorg.0.log. Wacom stylus is no longer listed as input device. Note that the installation was done with Fedora 12 LiveCD.
Comment 5 Adam Williamson 2009-10-23 03:04:19 EDT
peter: is the assignee of this bug correct or should it be re-assigned? I don't see Aristeu's name in the changelog since January.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 6 Aristeu Rozanski 2009-10-23 10:12:47 EDT
Please reassign, I don't have time to work on wacom bugs anymore.
Comment 7 Adam Williamson 2009-10-23 15:42:09 EDT
Re-assigning to Peter for now. Aristeu, I think if you don't have time to work on it you should give the package to someone else, then the bugs won't come to you.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 8 Peter Hutterer 2009-10-27 02:40:53 EDT
Adam: you can leave wacom bugs with me though I'm a bit flooded too. If you find another maintainer, I wouldn't complain :)


(In reply to comment #1)
> After running xsetwacom, here is the result:

xsetwacom parses the xorg.conf file. since we -in most cases- don't have one anymore, the tool is essentially obsolete.

As for the rest - I'll try to get linuxwacom updated to the latest tarball, but I can't do this before F12 GA, too many chances of regressions.
Comment 9 Luya Tshimbalanga 2009-10-27 14:22:36 EDT
(In reply to comment #8)
> xsetwacom parses the xorg.conf file. since we -in most cases- don't have one
> anymore, the tool is essentially obsolete.
> 
> As for the rest - I'll try to get linuxwacom updated to the latest tarball, but
> I can't do this before F12 GA, too many chances of regressions.  

Good to know. Perhaps an announcenement should be written for TabletPC users about the issue, otherwise complains will be abundant.
Comment 10 Adam Williamson 2009-10-27 21:37:58 EDT
I can add something to the common bugs, but it'd be nice to know precisely what the radius is - is it only going to affect certain types of hardware or is everything broken?

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Luya Tshimbalanga 2009-10-28 14:29:21 EDT
Force Device (use of stylus on screen) is broken for Tablet PC (in my case LG XNote LT-20 but others like ThinkPad X61 might have same issue). Other tablets like Bamboo, Intuos series are unaffected.
Comment 12 Dwayne Fontenot 2009-10-28 15:52:40 EDT
X61 tablet here.
The stylus at least partially works.
I can move the cursor by hovering and left click by tapping the tip just fine.
However, holding the side button down and tapping seems to be middle button
where I would expect it to be right button.
I don't have a way to do right button AFAICT.
I am willing to debug further as directed.
Comment 13 Luya Tshimbalanga 2009-10-29 03:04:48 EDT
After today update (20091028), the stylus is working once again. I first thought using xorg.conf did the trick until I completely removed it to confirm style indeed  is partially functional like comment #12 stated. I am not sure what caused the fix (maybe xorg-x11-drv-intel). 

Adam, because of update I think there is no longer need to put as common bug although linuxwacom should match upstream (maybe development version). Should this bug be closed or renamed to synchronize with upstream package?
Comment 14 Adam Williamson 2009-10-29 12:58:55 EDT
probably close it, so we don't have a confusing comment base, and file a new bug to request the version update.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.