Bug 530448 - RFE: virt-manager should provide a means to refresh storage pools
RFE: virt-manager should provide a means to refresh storage pools
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
: 569839 608243 (view as bug list)
Depends On:
Blocks: F13VirtTarget
  Show dependency treegraph
 
Reported: 2009-10-22 16:31 EDT by Paul Jenner
Modified: 2011-03-14 04:25 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-21 14:20:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Jenner 2009-10-22 16:31:41 EDT
Description of problem:

virt-manager should provide a means to refresh storage pools (other than stop and start of pool).

Example case:

* manually move install ISOs to a storage pool location on libvirt host so guests can be installed from them
* open the storage pool in virt-manager (via host Details and Storage tab) and the ISOs are not available in the pool
* there is no operation available in virt-manager to refresh the pool other than a full start and stop of the pool (unless I missed it in the UI?)
* use virsh shell to "refresh-pool"
* the ISOs are now shown as available in the storage pool in virt-manager

This should not require virsh shell to accomplish - virt-manager should either expose a means to refresh the pool or should issue a refresh each time the pool is accessed in the UI.

Note - this is with virt-manager connecting to a remote libvirt host so may be different when virt-manager is run locally.

Version-Release number of selected component (if applicable):
[psj@localhost ~]$ rpm -q virt-manager
virt-manager-0.8.0-7.fc11.noarch

(this is on F11 with virt-preview repo)
Comment 1 Mark McLoughlin 2009-10-29 13:01:44 EDT
I'm guessing the refresh doesn't happen automatically because of performance concerns in certain cases; in that case, a refresh button would make sense
Comment 2 Cole Robinson 2010-03-02 16:54:20 EST
*** Bug 569839 has been marked as a duplicate of this bug. ***
Comment 3 Paul Jenner 2010-07-05 16:55:55 EDT
Functionality is in virt-manager-0.8.4-2 (tested on F13 + virt preview) and in upstream via commit http://hg.fedorahosted.org/hg/virt-manager/rev/679b824e92dc

I am happy to close this if you are Cole?

Minor thought is that there is no tooltip for the refresh button (at least in F13 + virt preview) but the icon is probably clear enough.
Comment 4 Коренберг Марк 2011-03-14 04:25:37 EDT
*** Bug 608243 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.