This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 53049 - Rhn_register fails on redhat-6.2 sparc
Rhn_register fails on redhat-6.2 sparc
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
unspecified
sparc Linux
high Severity high
: ---
: ---
Assigned To: Cristian Gafton
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-02 13:52 EDT by Need Real Name
Modified: 2015-01-07 18:51 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-08 13:39:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console errors while running rhn_register (1.20 KB, text/plain)
2001-09-02 13:55 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-09-02 13:52:54 EDT
Description of Problem:
rhn_register start and runs up2date to register, takes information on user
and then check arch -- error displays in GUI 
( Red Hat Linux version: ERROR 
CPU model sparc
CPU  speed  0 MHZ) , 

proceeding with registration process queries installed packages
after system profile is collected, trying to send registration information
just returns pop-up window error about Problem Registering system
 
Version-Release number of selected component (if applicable):

up2date-2.5.4-0.6.x.sparc.rpm 
up2date-gnome-2.5.4-0.6.x.sparc.rpm
rhn_register-1.3.2-0.6.x.noarch.rpm
rhn_register-gnome-1.3.2-0.6.x.noarch.rpm
python-1.5.2-27.6.x.sparc.rpm
python-xmlrpc-1.4-0.6.x.sparc.rpm



How Reproducible:
above

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:
failure to register system profile 

Expected Results:
it to work

Additional Information:
	
repeatable
Comment 1 Need Real Name 2001-09-02 13:55:43 EDT
Created attachment 30611 [details]
console errors while running rhn_register
Comment 2 Todd Warner 2001-09-04 22:02:31 EDT
---- snip snip ----
Traceback (innermost last):
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in __call__
    ret = apply(self.func, a)
  File "/usr/share/rhn/register/gui.py", line 446, in onProfilePagePrepare
    label.set_text(rhnreg.getVersion())
  File "/usr/share/rhn/register/rhnreg.py", line 121, in getVersion
    index = db.findbyprovides("redhat-release")[0]
IndexError: list index out of range
---- snip snip ----

We've seen this before, I believe. Please send the output of
rpm -qa | grep redhat-release

I'm thinking either (a) you don't have that package installed or (b)... 
something else is up. If that package is legit, try an rpm --rebuilddb

Please followup with your outcome.
From our end, we'll try to wrap that call in a sane manner as to send a
sensible error message.
Comment 3 Need Real Name 2001-09-05 19:44:17 EDT
a. output of "rpm -qa | grep redhat-release"  redhat-release-6.2-1

b. did rpm --rebuilddb 

c. reran rhn_register

d. out is below
 
    I should note that the earlier error was from the GUI.  The error below is 
from the CLI version .

e. When running from A window managed env., I was able to register the machine 
( even though it still thought that the Mhz of the machine was 0.  After that I 
ran up2date and recieved another error " There was a fatal communication with 
the server. The message was:

ERROR CLASS CODE: 17
ERROR CLASS INFO: FILE NOT FOUND
ERROR MESSAGE: Invalid RPM package ['gnorpm','0.9.5.1','5.6x',"] requested 
explanation: blah blah report bug to rhn-help@redhat.com



####THIS IS THE CLI VERSION ERROR #############################
Traceback (innermost last):
  File "/usr/sbin/rhn_register", line 119, in ?
    main()
  File "/usr/sbin/rhn_register", line 100, in main
    tui.main()
  File "/usr/share/rhn/register/tui.py", line 1033, in main
    tui.run()
  File "/usr/share/rhn/register/tui.py", line 982, in run
    win = self.windows[index](self.screen, self)
  File "/usr/share/rhn/register/tui.py", line 422, in __init__
    self.emailContactButton.setValue("*")
AttributeError: setValue
Comment 4 Mihai Ibanescu 2001-09-06 13:15:51 EDT
Could you please try it again and see if gnorpm is still reported as missing? We
had a caching issue and it should be solved now. Thanks.
Comment 5 Todd Warner 2001-09-06 17:40:54 EDT
"rpm --rebuilddb" did indeed fix your original problem. The next issue is now
solved (since there are not all that many sparc users you stumbled upon a 
strange, esoteric error that we did not catch). That caching issue is now
rectified.

The tui.py error has been fixed and is currently in our beta OS code 
(roswell). The code will not be officially released just yet, but that should 
not hinder your use of the software for the moment.

Therefore, please respond to misa's request and if all is well, this bugzilla 
entry will be closed.

 
Comment 6 Need Real Name 2001-09-08 13:39:25 EDT
resolved. 
up2date is working normally. 
I must say that iwas impressed to see that redhat worked on a bug for a product 
that they no longer dist(redhat-sparc)., and would hopefully see in the future.
Comment 7 Jay Turner 2001-09-10 09:42:39 EDT
Closing out this issue as it appears that it is fixed.

Note You need to log in before you can comment on or make changes to this bug.