Bug 530558 - glibc should close all open file descriptors before exec()-ing pt_chown
glibc should close all open file descriptors before exec()-ing pt_chown
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
12
All Linux
high Severity medium
: ---
: ---
Assigned To: Andreas Schwab
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-23 09:05 EDT by Mark McLoughlin
Modified: 2010-01-12 18:43 EST (History)
7 users (show)

See Also:
Fixed In Version: 2.11.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-12 18:43:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-10-23 09:05:33 EDT
The basic argument is that, while applications should mark most of its file descriptors with O_CLOEXEC, it may legitimately not want to set that flag when it wants to pass the fd to child processes.

The application cannot reliably predict when glibc will exec programs like pt_chown, so it cannot know when it needs to set O_CLOEXEC

See bug #528134 for more background
Comment 1 Bug Zapper 2009-11-16 09:07:04 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Ulrich Drepper 2009-11-24 21:53:43 EST
I have changed the upstream code.  But grantpt is really a special case because it is transparent that pt_chown is used at all.  If there are other fork problems the arguments here don't apply.

The patch can be backported.
Comment 3 Fedora Update System 2009-11-30 11:35:46 EST
glibc-2.11-4 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/glibc-2.11-4
Comment 4 Fedora Update System 2009-12-01 23:26:01 EST
glibc-2.11-4 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update glibc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12470
Comment 6 Fedora Update System 2010-01-05 17:45:24 EST
glibc-2.11.1-1 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update glibc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12470
Comment 7 Fedora Update System 2010-01-12 18:42:48 EST
glibc-2.11.1-1 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.