Bug 530603 - Loads of "unknown actions" in GNOME keybindings
Loads of "unknown actions" in GNOME keybindings
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-10-23 13:34 EDT by Bastien Nocera
Modified: 2009-10-30 13:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-30 13:04:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2009-10-23 13:34:54 EDT
compiz-gnome-0.8.2-15.fc12.x86_64

Those actions show up as "<Unknown Action>" in gnome-keybinding-properties because the GConf keys lack a short description.

Note that a lot of those options shouldn't even be shown by default, compared to Metacity's options.

Marking as a blocker because Compiz is in the default Live install, and it makes GNOME look very unpolished.

(gnome-keybinding-properties:2464): keybinding-properties-WARNING **: No description for key '/apps/compiz/gnomecompat/allscreens/options/run_key'

(gnome-keybinding-properties:2464): keybinding-properties-WARNING **: No description for key '/apps/compiz/gnomecompat/allscreens/options/main_menu_key'

(gnome-keybinding-properties:2464): keybinding-properties-WARNING **: No description for key '/apps/compiz/gnomecompat/allscreens/options/run_command_screenshot_key'

(gnome-keybinding-properties:2464): keybinding-properties-WARNING **: No description for key '/apps/compiz/gnomecompat/allscreens/options/run_command_window_screenshot_key'

(gnome-keybinding-properties:2464): keybinding-properties-WARNING **: No description for key '/apps/compiz/gnomecompat/allscreens/options/run_command_terminal_key'

(gnome-keybinding-properties:2464): keybinding-properties-WARNING **: No description for key '/apps/compiz/general/allscreens/options/opacity_decrease_key'

(gnome-keybinding-properties:2464): keybinding-properties-WARNING **: No description for key '/apps/compiz/general/allscreens/options/opacity_increase_key'
Comment 1 Matthias Clasen 2009-10-26 11:17:59 EDT
Here are my findings:

<mclasen> drago01: hey, it appears to me that the 'unknown key' shows up in the keybinding capplet
<mclasen> because all the key names in the keybinding xml files lack the '/plugins/'  path element
<mclasen> running  sed -i -e 's#compiz/gnomecompat#compiz/plugins/gnomecompat#' 50-compiz-*
<mclasen> makes all the unknown keys go away
<mclasen> execpt for 2: opacity_{increase,decrease}_key
<mclasen> those seem to be missing in the schemas
Comment 2 Adam Williamson 2009-10-30 13:04:18 EDT
Fix is http://koji.fedoraproject.org/koji/buildinfo?buildID=139026 , which has been tagged for final - https://fedorahosted.org/rel-eng/ticket/2912 . I tested this build and it seems fine; no problematic entries in gnome-keybinding-properties .

oxf13 notes that "you shouldn't see Increase or Decrease when running metacity" (meaning opacity), but I don't believe that's really the same bug, and doesn't seem like a blocker.

closing, please re-open if there's anything left to do on this one, but I think for the 'don't show inappropriate actions for the running wm' bug, we'd want a new report, it's not the same as this AFAICS.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.