Bug 530660 - KDM ignores /etc/kde/kdm/Xservers file, and always starts X server
KDM ignores /etc/kde/kdm/Xservers file, and always starts X server
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Reopened
: 530661 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-23 20:39 EDT by Charlweed Hymerfan
Modified: 2009-10-27 19:31 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 19:31:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charlweed Hymerfan 2009-10-23 20:39:18 EDT
Description of problem:

KDM ignores /etc/kde/kdm/Xservers file, and always starts X server

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Comment out local x server line in /etc/kde/kdm/Xservers, as specified in the documentation:

#:0 local /usr/bin/X :0 
2. Switch runlevel to 3, and then back to 5

  
Actual results:
X server starts, and display tries to open

Expected results:
X server should not start.

Additional info:

I am following the established procedure for running XDMCP, headless. But this bug makes that impossible.  Bug 452528 blocks the same functionality for GDM.
Comment 1 Charlweed Hymerfan 2009-10-23 20:41:20 EDT
Wrong value in bugzilla component chooser
Comment 2 Kevin Kofler 2009-10-23 20:43:37 EDT
The component can be changed. :-)
Comment 3 Kevin Kofler 2009-10-23 21:36:09 EDT
*** Bug 530661 has been marked as a duplicate of this bug. ***
Comment 4 Charlweed Hymerfan 2009-10-25 18:00:07 EDT
Found this bug in the KDE bug tracking system, and it's tagged as WONTFIX.

But I also found a workaround:
http://bugs.kde.org/show_bug.cgi?id=101163
So basically its the Documentation that is wrong, and the fact that a useless softlink is created in the /etc/kde/kdm directory. 

Put a blank in StaticServers, set ServerAttempts=0 , ServerCmd=/bin/true, and remove all X-:0- sections.

For example:

[General]
ConfigVersion=2.3
ConsoleTTYs=tty2,tty3,tty4,tty5,tty6
PidFile=/var/run/kdm.pid
ReserveServers=:1,:2,:3
ServerVTs=1
StaticServers=

[Shutdown]
BootManager=Grub
HaltCmd=/sbin/poweroff
RebootCmd=/sbin/reboot

[X-*-Core]
AllowShutdown=Root
AutoReLogin=false
ClientLogFile=.xsession-errors-%d
Resources=/etc/X11/xdm/Xresources
Session=/etc/kde/kdm/Xsession
SessionsDirs=/usr/share/xsessions,/usr/share/kde4/apps/kdm/sessions
Setup=/etc/X11/xdm/Xsetup_0
ServerAttempts=0
StartAttempts=0
ServerCmd=/bin/true


[X-*-Greeter]
AntiAliasing=true
BackgroundCfg=/etc/kde/kdm/backgroundrc
ColorScheme=ObsidianCoast
EchoPasswd=true
FaceSource=PreferUser
FailFont=Abyssinica SIL,12,-1,5,50,0,0,0,0,0
FocusPasswd=true
ForgingSeed=1108476160
GUIStyle=
GreetFont=Abyssinica SIL,16,-1,5,50,0,0,0,0,0
GreetString=Fedora 11 (Leonidas)
GreeterPos=50,50
Language=en_US
LogoArea=Logo
LogoPixmap=/usr/share/icons/hicolor/96x96/apps/fedora-logo-icon.png
MaxShowUID=65530
MinShowUID=500
SelectedUsers=
ShowUsers=NotHidden
SortUsers=true
StdFont=Abyssinica SIL,10,-1,5,50,0,0,0,0,0
Theme=/usr/share/kde4/apps/kdm/themes/leonidas
UseBackground=true
UseTheme=true
UserCompletion=true
UserList=true

[X-:*-Core]
AllowShutdown=All
NoPassEnable=false
NoPassUsers=
ServerArgsLocal=-br -nolisten tcp
ServerTimeout=30
TerminateServer=true


[X-:*-Greeter]
DefaultUser=chymes
FocusPasswd=true
LoginMode=DefaultLocal
PreselectUser=Previous

#[X-:0-Core]
#AutoLoginEnable=false
#AutoLoginLocked=false
#AutoLoginUser=

[Xdmcp]
Enable=true
Willing=/etc/X11/xdm/Xwilling
Xaccess=/etc/X11/xdm/Xaccess
Comment 5 Kevin Kofler 2009-10-26 01:04:40 EDT
So I guess the real bug is that kde-settings-kdm creates that unused Xservers symlink.
Comment 6 Rex Dieter 2009-10-27 19:31:59 EDT
%changelog
* Tue Oct 27 2009 Rex Dieter <rdieter@fedoraproject.org> 4.3-12
- plasma-desktop-appletsrc: Constantine wallpaper
- drop /etc/kde/kdm/Xservers (#530660)

Note You need to log in before you can comment on or make changes to this bug.