This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 530663 - SELinux is preventing /usr/bin/xauth "write" access on .xauth7rfxHb.
SELinux is preventing /usr/bin/xauth "write" access on .xauth7rfxHb.
Status: CLOSED DUPLICATE of bug 531530
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:7fc23df8d65...
: Reopened
: 530662 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-23 21:10 EDT by Gideon Mayhak
Modified: 2009-10-29 09:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-29 09:01:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
audit.log (338.94 KB, application/octet-stream)
2009-10-28 21:38 EDT, Gideon Mayhak
no flags Details

  None (edit)
Description Gideon Mayhak 2009-10-23 21:10:38 EDT
Summary:

SELinux is preventing /usr/bin/xauth "write" access on .xauth7rfxHb.

Detailed Description:

SELinux denied access requested by xauth. It is not expected that this access is
required by xauth and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Please file a bug
report.

Additional Information:

Source Context                unconfined_u:unconfined_r:xauth_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:admin_home_t:s0
Target Objects                .xauth7rfxHb [ file ]
Source                        xauth
Source Path                   /usr/bin/xauth
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           xorg-x11-xauth-1.0.2-7.fc12
Target RPM Packages           
Policy RPM                    selinux-policy-3.6.32-33.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     (removed)
Platform                      Linux (removed) 2.6.31.1-56.fc12.x86_64
                              #1 SMP Tue Sep 29 16:16:22 EDT 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Fri 23 Oct 2009 08:07:31 PM CDT
Last Seen                     Fri 23 Oct 2009 08:07:31 PM CDT
Local ID                      cb374e0b-16f6-4191-be8a-b55e5c007008
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1256346451.635:23608): avc:  denied  { write } for  pid=1957 comm="xauth" name=".xauth7rfxHb" dev=sda6 ino=10456 scontext=unconfined_u:unconfined_r:xauth_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:admin_home_t:s0 tclass=file

node=(removed) type=SYSCALL msg=audit(1256346451.635:23608): arch=c000003e syscall=21 success=no exit=-13 a0=7fff406af61e a1=2 a2=0 a3=7fff406adb60 items=0 ppid=1950 pid=1957 auid=500 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=pts0 ses=1 comm="xauth" exe="/usr/bin/xauth" subj=unconfined_u:unconfined_r:xauth_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  selinux-policy-3.6.32-33.fc12,catchall,xauth,xauth_t,admin_home_t,file,write
audit2allow suggests:

#============= xauth_t ==============
allow xauth_t admin_home_t:file write;
Comment 1 Daniel Walsh 2009-10-24 08:31:24 EDT
Please run restorecon -R -v /root 

And  see if this happens again.  I think this is just a mislabling that was fixed with the -32 package and once your labeling is correct, will not happen again.

If it does happen again please reopen the bugzilla.
Comment 2 Daniel Walsh 2009-10-24 08:31:57 EDT
*** Bug 530662 has been marked as a duplicate of this bug. ***
Comment 3 Gideon Mayhak 2009-10-28 21:38:16 EDT
Created attachment 366528 [details]
audit.log

I wanted to open this back up quick.  Feel free to close it again if appropriate.

I noticed that I get a lot of these kind of messages when I use su - or su -c.  Everything seems to work fine, so I guess there's no harm, but perhaps these warnings shouldn't be happening if su - or su -c is expected to work fine.
Comment 4 Daniel Walsh 2009-10-29 09:01:52 EDT

*** This bug has been marked as a duplicate of bug 531530 ***

Note You need to log in before you can comment on or make changes to this bug.