Bug 530700 - firstboot errors when loading modules: no module rhpl.iconv
firstboot errors when loading modules: no module rhpl.iconv
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 530320
  Show dependency treegraph
 
Reported: 2009-10-24 06:14 EDT by Michal Hlavinka
Modified: 2009-10-26 11:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 530320
Environment:
Last Closed: 2009-10-26 11:43:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Hlavinka 2009-10-24 06:14:34 EDT
+++ This bug was initially created as a clone of Bug #530320 +++

Description of problem:
when firstboot shows up after F-12 beta installation, some modules are missing (for example smolt) and following messages are printed to boot windows:

...
...
No module named rhpl.iconv

Loading /lib/kbd/keymaps/i386/querty/us.map.gz
...
...

Version-Release number of selected component (if applicable):
firstboot-1.110-1.fc12.x86_64


Steps to Reproduce:
1.install F-12 beta
2.
3.
  
Actual results:
some modules are missing, prints error messages

Expected results:
no modules missing, no error messages


maybe this is caused because rhpl package is not installed?
Comment 1 Chris Lumens 2009-10-26 11:33:48 EDT
There is no rhpl package anymore, and at no point does firstboot "import rhpl.iconv", so this can't possibly be a firstboot bug.  Can you provide more context here?
Comment 2 Chris Lumens 2009-10-26 11:35:21 EDT
Bug 530320 shows this is in smolt:

usr/share/smolt/client/smoltFirstBoot.py:import rhpl.iconv

Reassigning.
Comment 3 Mike McGrath 2009-10-26 11:43:33 EDT
Already fixed, just missed the beta.

Note You need to log in before you can comment on or make changes to this bug.