Bug 530711 - ibus preloaded engines could be updated with other engines when login language is changed.
ibus preloaded engines could be updated with other engines when login languag...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
: i18n, Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-24 08:05 EDT by Runa Bhattacharjee
Modified: 2013-03-03 21:21 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-10 03:30:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Runa Bhattacharjee 2009-10-24 08:05:20 EDT
Description of problem:

The list of keymaps displayed in the ibus preferences and the default keymap, do not change to display the appropriate list and default value (as per the earlier Fedora versions), when the language is changed from the login-manager.

Version-Release number of selected component (if applicable):

ibus-1.2.0.20091014-2.fc12.i686

How reproducible:


Steps to Reproduce:
1. Install Fedora in the system in a language which uses ibus IM.

2. During installation-package selection-language-support, select multiple  languages which have separate keymaps in ibus e.g. Hindi support, Malayalam support, Bengali support. 

3.Post-installation, log in via the login-manager (e.g. gdm) using the same language that was used for installation

4. Open a text-editor and trigger the input method. 

5. Right-click on the ibus icon and go to the 'Preferences' dialog. The list of keymaps for the language would be displayed. The default keymap is marked in bold.

http://runab.fedorapeople.org/assorted-bugs/ibus-km1.png

(language selected for this login is: Bengali-India)

6. Log-out and return to the login-manager

7. Select a different language from the list and log-in again.

8. Open a text-editor and trigger the input method. 

9. Right-click on the ibus icon and go to the 'Preferences' dialog.
  
Actual results:

The list of keymaps for the language are not displayed. The keymap list still displays the keymaps from the earlier login.

http://runab.fedorapeople.org/assorted-bugs/ibus-km2.png

(language selected for this login: Malayalam)
(keymaps displayed: Bengali-India )


Expected results:

If the language-support (that includes the ibus keymap packages) are installed then the list of keymaps for the logged in language should be displayed in the keymap list (preferably at the top) and the default keymap identified for the language should be automatically selected.

http://runab.fedorapeople.org/assorted-bugs/ibus-km3.png

(language selected for this login: Malayalam)
(keymaps displayed here: Malayalam, Bengali India)
(default keymap selected here: Malayalam-inscript)


Additional info:
1. Currently, the keymaps for the language logged in second (in this case Malayalam) needs to be manually added by the user and the default keymap selected as well.
Comment 1 Peng Huang 2009-10-25 22:09:39 EDT
Hi Runa,

Ibus just setup keymaps for users at the first time login automatically. After the first login, ibus will not change the keymap list anymore. If users want to change it, they have to modify the list by self. So it is not a bug.
Comment 2 Jens Petersen 2009-11-09 00:08:13 EST
Some face-to-face discussion on this.

Various options suggestions made including:

- include new IME
- dialogue confirming change of lang, etc
Comment 3 Bug Zapper 2009-11-16 09:11:17 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Fedora Admin XMLRPC Client 2010-08-02 02:09:22 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Jens Petersen 2010-09-01 03:02:11 EDT
Hmm I think it is a smaller thing but would be better
to distinguish between default and user setting.

If you logins in to Japanese and then logs out and
starts a new session in another language with IM default
then it seems more natural to change the default IME
unless the user has changed the IME specifically.

On the other hand imsettings could even disable IM
if one changes desktop locale to one that doesn't use IM say.

Anyway normally users don't change their language frequently
so I think this is a minor annoyance.
Comment 6 fujiwara 2010-09-01 03:23:17 EDT
Probably I agree with that request.
Changing the synopsis slightly to clear the request.
Probably I think prev-language gconf key could be saved.

Workaround:
Clear gconf key of /desktop/ibus/general/preload_engines by manual and log in again.
Comment 7 fujiwara 2010-09-01 03:26:25 EDT
Workaround2:
Invoke ibus-setup and cleanup all listed IM engines.

Then there is one concern.
If users already customize the preloaded engines, probably they won't initialize the preloaded engines even thought the login language is changed.
Comment 8 fujiwara 2010-09-01 03:42:19 EDT
Probably I think initializing the preloaded list might not be good. Updating the list might be good.
Comment 10 fujiwara 2010-09-03 05:30:55 EDT
Revised the patch.
http://github.com/fujiwarat/ibus/commit/fe5e4f6aec0b3e42cb52d42f15a8bf0b09a9416f

Added use_preload_engines_system for the back compatibility.
Comment 11 fujiwara 2010-09-03 05:44:40 EDT
Test Package for f13:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2444991
Comment 12 fujiwara 2010-11-12 05:02:46 EST
We have discussed the implementation of preload engines.
https://github.com/fujiwarat/ibus/commit/8d29b30a2ad09a1e7cf840655e23018d41201436

Integrated it into rawhide since probably we reached the good implementation.
http://koji.fedoraproject.org/koji/taskinfo?taskID=2596583
Comment 13 Jens Petersen 2010-11-29 22:16:39 EST
Seems to work well thanks!
Comment 14 fujiwara 2011-02-10 03:30:40 EST
There are some thoughts about the feature.
We decided to integrate this feature in f15 if we can get more feedback.

I'll discuss the patch in f16 term again.

Note You need to log in before you can comment on or make changes to this bug.