Bug 530717 - update for opencv, 2.0.0 gold released
Summary: update for opencv, 2.0.0 gold released
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: opencv
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Rakesh Pandit
QA Contact: Fedora Extras Quality Assurance
URL: http://sourceforge.net/projects/openc...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-24 13:05 UTC by Sebastian Krämer
Modified: 2009-12-20 16:11 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-20 16:11:47 UTC


Attachments (Terms of Use)

Description Sebastian Krämer 2009-10-24 13:05:13 UTC
It would be nice to have the new version of opencv available. AFAIK it's supposed to be backward compatible so in terms of API it should not break anything..

Comment 1 Haïkel Guémar 2009-10-25 10:17:15 UTC
With kwizart, we did some investigations and i have both good and bad news:
* good news: it builds fine, most patches have been integrated by upstream and other are likely obsoleted. The build infrastructure is much more saner than it was. Note that I stuck with autotools, since my trials with cmake resulted with much slower build times.
http://koji.fedoraproject.org/koji/taskinfo?taskID=1766715

* bad news: it seems not to be backward compatible, it utterly breaks vlc
http://fpaste.org/ONoV/

packages concerned:
* fedora : player, mrpt-core, php-facedetect, frei0r-plugins
* 3rd party : vlc

Comment 2 Nicolas Chauvet (kwizart) 2009-10-25 11:10:09 UTC
(In reply to comment #1)
Thx for your work Haïkel!

> * bad news: it seems not to be backward compatible, it utterly breaks vlc
> http://fpaste.org/ONoV/
Actually we are hitten by a problem that was already present in previous opencv releases:
The opencv installed include (cxmisc.h) shows:
------------------
#ifdef HAVE_CONFIG_H
    #include "cvconfig.h"
#endif
------------------
That's incorrect as no "config.h like header" should be allowed in the API.
That's even more incorrect as it should have been either:
HAVE_CONFIG_H -> #include "config.h"
HAVE_CVCONFIG_H ->  #include "cvconfig.h"

grep HAVE_ /usr/include/opencv/* -R
show lot of HAVE_ define that will have to be fixed.

Moved to rawhide as this will not be fixed in F-11

Comment 3 Haïkel Guémar 2009-10-25 15:29:42 UTC
As you suggested, including cvconfig.h in -devel subpackage fixes build issues for all packages previously mentionned. This is fugly but it was already present in previous releases.
I did some tests with opencv2 powered vlc, basically, opencv processing within vlc works fine. I had some crashes with vlc's Qt interface but not related to OpenCV since I was able to reproduce it with rpmfusion current build (1.0.2-2.fc2 with opencv 1.1.0-0.7.pre1.fc12)

I resubmitted another scratch build.
http://koji.fedoraproject.org/koji/taskinfo?taskID=1766863
I don't know why but it hangs at the check part on ppc64.

Comment 4 Bug Zapper 2009-11-16 14:11:38 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 5 Haïkel Guémar 2009-11-25 12:22:11 UTC
Sorry for the hiatus.
Looks like it's too hard to fix that check issue on ppc64 without a ppc64 machine.

Since ppc64 is no more a primary architecture,and disabling check on ppc64 [1] allows us to build the package, i suggest we move forward. 
If nobody disagree, a build will be submitted to updates-testing within few days.

For packages depending on openCV, maintainers will be required to recompile their packages.

[1] http://koji.fedoraproject.org/koji/taskinfo?taskID=1828033

Comment 6 Nicolas Chauvet (kwizart) 2009-11-25 13:23:25 UTC
I disagree.
This have to be rawhide only at this time.

It can be re-evaluated later, But I want to split the testing in rawhide task from backport in stable. Doing the whole thing in a raw seems unappropriate as we have an ABI bump, and huge software depend on opencv such as vlc.

Comment 7 Haïkel Guémar 2009-11-25 14:07:51 UTC
That's fine for me. 
I have been using it in production for a month without any glitches (except recompiling packages), but more testing might debunk unencountered issues.

I'll push this later in rawhide.

Comment 8 Nicolas Chauvet (kwizart) 2009-11-30 08:29:28 UTC
Packagers of packages that depends upon opencv are expected to rebuild their packages now for rawhide.
ABI bump message should have been sent to the announce-list.

Comment 9 Rakesh Pandit 2009-11-30 08:35:14 UTC
@ Haïkel Guémar

Now that you have pushed an update. May you inform all maintainer to rebuild the consumers of this package ABI or rebuild them yourself. rawhide update is broken because of this.

Thanks,

Comment 10 Andrew Colin Kissa 2009-11-30 09:20:34 UTC
php-facedetect done, - https://koji.fedoraproject.org/koji/taskinfo?taskID=1837084

Comment 11 Haïkel Guémar 2009-11-30 14:12:02 UTC
My deepest apologies for not having updated the ticket right after building the package. 
Added rdieter to the CC list as primary maintainer of kipi-plugins.

Comment 12 Rex Dieter 2009-11-30 14:19:21 UTC
kipi-plugins is rebuilt

Comment 13 Haïkel Guémar 2009-12-06 12:17:00 UTC
An update (opencv-2.0.0-2) has been commited (ticket #544167) in rawhide, no ABI changes, (it only adds an executable and a data file).

Comment 14 Nicolas Chauvet (kwizart) 2009-12-20 16:11:47 UTC
player still need a rebuild, no update is planned for F-12. Closing for rawhide.


Note You need to log in before you can comment on or make changes to this bug.