This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 530724 - koan bundles optparse, subprocess, textwrap Python modules
koan bundles optparse, subprocess, textwrap Python modules
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: koan (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: John Eckersberg
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: DuplicSysLibsTracker
  Show dependency treegraph
 
Reported: 2009-10-24 11:07 EDT by Cristian Ciupitu
Modified: 2010-08-18 18:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 18:20:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FedoraHosted Cobbler 523 None None None Never

  None (edit)
Description Cristian Ciupitu 2009-10-24 11:07:48 EDT
Description of problem:
koan comes with its own subprocess and optparse modules: /usr/lib/python2.6/site-packages/koan/opt_parse.py and /usr/lib/python2.6/site-packages/koan/opt_parse.py.

Additional info:
Mail list thread: https://fedorahosted.org/pipermail/cobbler-devel/2009-October/001296.html
Comment 1 Cristian Ciupitu 2009-10-24 11:24:49 EDT
(In reply to comment #0)
> koan comes with its own subprocess and optparse modules:.
Errata: /usr/lib/python2.6/site-packages/koan/sub_process.py
Comment 2 Cristian Ciupitu 2009-10-30 12:50:39 EDT
Upstream bug: https://fedorahosted.org/cobbler/ticket/523
Comment 3 Cristian Ciupitu 2009-11-06 22:10:37 EST
I've discovered another bundled library: textwrap as /usr/lib/python2.6/site-packages/koan/text_wrap.py.
Comment 4 Patrick Dignan 2010-08-16 20:41:53 EDT
Cristian, it looks like your patches for this got merged into Cobbler 2.0.2, and the version in Fedora is currently 2.0.5, so this issue is resolved, correct?
Comment 5 Cristian Ciupitu 2010-08-18 03:35:47 EDT
Yes, that's correct.
Comment 6 Patrick Dignan 2010-08-18 18:20:16 EDT
Fixed upstream thanks to Cristian's patches. Closing this one as well.

Note You need to log in before you can comment on or make changes to this bug.