Bug 530727 - eee901 rt2860 wireless hotkey not working
eee901 rt2860 wireless hotkey not working
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: 0xFFFF (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-24 11:29 EDT by Ali Alhakim
Modified: 2009-10-27 17:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-27 17:07:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update log file (6.93 KB, text/plain)
2009-10-24 11:29 EDT, Ali Alhakim
no flags Details

  None (edit)
Description Ali Alhakim 2009-10-24 11:29:41 EDT
Created attachment 365952 [details]
Update log file

Description of problem:

Hello I'm confronting a problem with my Asus eee901 Netbook since the 2nd October when I upgraded my Fedora11. The wireless hotkey Fn+F2 for enabling/disabling wireless rt2860 is not working.  I don't see any reaction from the different logs when I try to enable/disable the wireless
 however I can enable the wireless adaptor from Bios and it is functioning.  
Is there any known bug about this problem? How can I manually enable the wireless module to investigate more? Other hotkeys are functioning as they should (suspend, display brightness, display switching , volume, mute).

 I suspect that the problem is due to the update kmod-rt2860-2.6.30.8-64.fc11.i686.PAE and/or Ibus updates
 because these updates that I recieved on october the 2nd. 
I've attached a part from the yum.log containing updates during 29September-2October.
BR
Ali


Note that I've verified that the hotkey works by running Fedora 11 liveCD and I could see that Ralink RT2860 disappears/ shows up when I press the Fn+F2 meanwhile checking the devices using the command lspci.

I've tried the Fedora mail list and Irc channel but it doesn't seems that this problem is recognized.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Fn+F2 does not turn on/off ralink RT2860 wireless device. No information in log files (dmesg, messages ...) when I press the hotkey.
Expected results:
Fn+F2 hotkey on Asus eee 901 should turn on/off the wireless device Ralink RT2860.


Additional info:
Comment 1 Peng Huang 2009-10-25 22:22:59 EDT
Are you using some input method? If yes, please use 'im-chooser' to disable input method, and test the Fn-F2 again. If it can fix this problem, maybe this issue is caused by ibus.
Comment 2 Ali Alhakim 2009-10-26 03:09:49 EDT
From the System menu>Preferences>Input method , the checkbox:"Enable input method feature" was unchecked.
I enabled the feature and Use ibus (recommended) was the only selection in input method list box. I logged out and restarted the system, the  icon ibus input framework showed up when I logged in. But still the same behaviour. The wireless device is not disabled, and the log files does not log in information when I press Fn+F2.
Comment 3 Peng Huang 2009-10-26 05:21:37 EDT
How about disable the ibus? Does Fn-F2 work?
Comment 4 Ali Alhakim 2009-10-26 07:56:14 EDT
The checkbox "Enable input method feature" was previously unchecked by standard. Does this mean that ibus is disabled? In that case Fn+F2 does not work when ibus is disabled as well as enabled.
Comment 5 Peng Huang 2009-10-27 00:55:18 EDT
So I think the problem is not in ibus.
Comment 6 Ali Alhakim 2009-10-27 03:07:22 EDT
Could You please give me advice about where should I forward this issue or how can I debug by myself. Obviously the problem is not related to ibus but as I mentioned in the problem description. The hotkey stopped to function after the updates in ibus and kmod-rt2860-2.6.30.8-64.fc11.i686.PAE.
What Fedora component is responsible for  kmod-rt2860-2.6.30.8-64.fc11.i686.PAE?

/thank You for Your help.
Comment 7 Michal Schmidt 2009-10-27 17:07:16 EDT
(In reply to comment #6)
> What Fedora component is responsible for 
> kmod-rt2860-2.6.30.8-64.fc11.i686.PAE?

None. Fedora does not include any kmod packages. You must have installed this package from a 3rd party repository, which has its own Bugzilla.

Note You need to log in before you can comment on or make changes to this bug.