Bug 530728 - abrt won't send bug report: 'Logger' is not registered
abrt won't send bug report: 'Logger' is not registered
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
rawhide
i686 Linux
low Severity high
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
: Triaged
: 530645 (view as bug list)
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-10-24 11:32 EDT by Tony White
Modified: 2015-02-01 17:49 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-11 12:00:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tony White 2009-10-24 11:32:58 EDT
Description of problem:
Automatic bug reporting tool fails to send report

Version-Release number of selected component (if applicable):
abrt - 0.0.10-1.fc12 (i686)
abrt-gui - 0.0.10-1.fc12 (i686)


How reproducible:
I can't send a bug report

Steps to Reproduce:
1. Bug accurs
2. abrt-gui launches automatically
3. Click report and then send
  
Actual results:
Popup message appears :

Bugzilla: CReporterBugzilla::Report(): CReporterBugzilla::CheckUUIDInBugzilla(): Unable to tr
Logger: CPluginManager::GetPluginType():Plugin: 'Logger' is not registered.

Expected results:
The report is sent.

Additional info:
If I use Edit > Preferences > Analysers, Actions, Reporters > Then click on the edit actions icon (Looks like a notepad and a pencil) To check that the user name and password are correct, nothing happens.

I'm using the kde version and bugs here will not send automatically.

Is there a way to retrieve a report from it's local location so that I can manually report it? Or even edit abrt's config manually?
Automatic bug reporting doesn't work here.
Comment 1 Jiri Moskovcak 2009-10-26 08:17:35 EDT
Try to run gui from terminal, you should be able to see some debug messages. The BZ settings are located in Edit -> Plugins.

Jirka
Comment 2 Tony White 2009-10-26 11:24:27 EDT
abrt-gui
Warning >>RunAnalyzerActions(): CPluginManager::GetPluginType():Plugin: 'Logger' is not registered.<<
Update >>Action performed by 'Logger' was not successful: 
OK. It worked that way here's the output from the terminal :

CPluginManager::GetPluginType():Plugin: 'Logger' is not registered.<<
Our job for UUID a632bfbd is done.
Warning >>RunAnalyzerActions(): CPluginManager::GetPluginType():Plugin: 'Logger' is not registered.<<
Update >>Action performed by 'Logger' was not successful: CPluginManager::GetPluginType():Plugin: 'Logger' is not registered.<<
Update >>Checking for duplicates...<<
Update >>Logging into bugzilla...<<
Update >>Creating new bug...<<
Update >>New bug id: 531027<<
Update >>Logging out...<<
Warning >>Report(): CPluginManager::GetPluginType():Plugin: 'Logger' is not registered.<<
Update >>Reporting via 'Logger' was not successful: CPluginManager::GetPluginType():Plugin: 'Logger' is not registered.<<
/usr/share/abrt/CC_gui_functions.py:86: GtkWarning: Unable to show 'https://bugzilla.redhat.com/show_bug.cgi?id=531027': Operation not supported
  ret = dialog.run()


I get a dialogue box saying :

Report Done.
Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=531027
Logger: CPluginManager::GetPluginType():Plugin: 'Logger' is not registered.

and the report goes through.
Comment 3 Christopher Beland 2009-10-27 11:05:29 EDT
*** Bug 530645 has been marked as a duplicate of this bug. ***
Comment 4 Denys Vlasenko 2010-02-11 12:00:16 EST
There is nothing to fix there. abrt is split into many .rpms, and if you install main abrt with default config file but do not install some plugins which are enabled there, you'll get this result.

For simple desktop use, just install abrt-desktop. It pulls in all required plugins.

Note You need to log in before you can comment on or make changes to this bug.