Bug 53076 - Unable to retrieve dhcp nameserver information
Summary: Unable to retrieve dhcp nameserver information
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-03 10:56 UTC by Leonid Kanter
Modified: 2014-03-17 02:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-04 13:13:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Leonid Kanter 2001-09-03 10:56:41 UTC
Description of Problem:

After "ifup eth0" nameserver line in /etc/resolv.conf is broken

Version-Release number of selected component (if applicable):

initscripts-6.34-1

How Reproducible:

always


How it happens:

[root@leon leon]# /sbin/ifup eth0
oPREDELQETSQ INFORMACIQ IP DLQ eth0... GOTOWO. (Russian :)
[root@leon leon]# grep nameserver /etc/resolv.conf
nameserver 19
[root@leon leon]# killall dhcpcd
[root@leon leon]# dhcpcd[root@leon leon]# grep nameserver /etc/resolv.conf
nameserver 193.178.236.130
nameserver 193.178.236.131
nameserver 213.130.10.10

Additional information: DHCP server 2.0pl5-4

Comment 1 Bill Nottingham 2001-09-03 13:07:30 UTC
Just to confirm, you are using dhcpcd?

Comment 2 Leonid Kanter 2001-09-03 13:58:32 UTC
Yes. I'm unable to reproduce this problem after system reboot - now everything
is OK. Described situation happened when I changed IP information from static to
DHCP and tried ifdown/ifup without reboot.

Comment 3 Bill Nottingham 2001-09-04 00:37:08 UTC
What did your resolv.conf look like when it was static?

Comment 4 Bill Nottingham 2001-09-04 00:38:17 UTC
(I can't reproduce this switching from a static to a dynamic IP address here.

Comment 5 Leonid Kanter 2001-09-04 13:13:36 UTC
During installation I configured the box for using 192.168.200.1. Now I have
following:

[leon@leon leon]$ vdir /etc/resolv.*   
-rw-r--r--    1 root     root          144 sEN  3 14:00 /etc/resolv.conf
-rw-r--r--    1 root     root           44 sEN  1 15:23 /etc/resolv.conf.bak
-rw-r--r--    2 root     root           41 sEN  3 12:29 /etc/resolv.conf.sv
[leon@leon leon]$ grep nameserver /etc/resolv.conf.bak /etc/resolv.conf.sv     
/etc/resolv.conf.bak:nameserver 192.168.200.1
/etc/resolv.conf.sv:nameserver 19
BTW, I'm still unable to reproduce described situation.

Comment 6 Bill Nottingham 2002-01-24 06:31:17 UTC
I don't see anything in initscripts that writes ".sv" files, so I'm going to
close this (since you also said you couldn't reproduce it.)

Comment 7 Leonid Kanter 2002-01-24 06:38:24 UTC
Yes, I'm unable to reproduce. May be closed


Note You need to log in before you can comment on or make changes to this bug.