Bug 53077 - ftpd-messages script typo causes alarming message in report
ftpd-messages script typo causes alarming message in report
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: logwatch (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-03 07:07 EDT by Tim Waugh
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-04 10:37:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2001-09-03 07:07:04 EDT
Description of Problem:
I get this in my logwatch mail:

 --------------------- ftpd-messages Begin ------------------------
 
User FTP Logins:
   turmoil.elk (192.168.1.7): tim - 1 Time(s)
 
exiting on signal 11: Segmentation fault:  Time(s)
 
 
 ---------------------- ftpd-messages End -------------------------

It looks funny, and I started to think that logwatch has segfaulted or 
something.  No 'segmentation fault' is in any of my log files.  It's a 
false alarm.

Version-Release number of selected component (if applicable):
2.1.1-2

How Reproducible:
100%

Steps to Reproduce:
1. Use the ftp server of a machine running logwatch.
2. Wait for logwatch to notice.

Actual Results:
Alarming messages in your mailbox.

Expected Results:
Useful report of FTP server usage. :-)

Additional Information:
It's caused by a typo in /etc/log.d/scripts/services/ftpd-messages, line 
150.  Suggested fix:

-if ($SegFault >= 0){
+if ($SegFault > 0){

Note You need to log in before you can comment on or make changes to this bug.