Bug 5308 - gnome-terminal doesn't handle large (>4096 byte) pastes correctly.
Summary: gnome-terminal doesn't handle large (>4096 byte) pastes correctly.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs   
(Show other bugs)
Version: 7.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-09-22 16:43 UTC by David Woodhouse
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-25 23:54:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Woodhouse 1999-09-22 16:43:26 UTC
1. Select a large amount of text.
2. Type 'cat > testfile' in a gnome-terminal
3. Point at your gnome-terminal and press the middle mouse
button.
4. Observe that only the first 4096 bytes of the text appear
to have been pasted.

Strangely, the actual size of the file sometimes appears to
end up correct - as if only the screen update is buggy. This
appears to depend on architecture. gnome-core-1.0.4 on sparc
appears to end up with the correct filesize, although it
still doesn't display correctly. gnome-core-1.0.4 on alpha,
and gnome-core-1.0.7-2 on i686 both end up with 4096 byte
files.

I used xemacs as the source of the text, and verified that
it's not emacs' problem by trying the 'cat' in an xterm.

Comment 1 David Woodhouse 1999-10-19 15:47:59 UTC
Fixed in October-GNOME.

Comment 2 Elliot Lee 1999-10-29 15:57:59 UTC
Reporter has indicated this is fixed in OG (which will go into updates
eventually).

Comment 3 David Woodhouse 2001-11-06 10:44:06 UTC
Seems to be broken again in the 7.2 release.

Comment 4 Havoc Pennington 2001-11-14 16:27:33 UTC
reassign to hp

Comment 5 Joe Harrington 2002-01-04 17:28:49 UTC
I confirm the behavior in 7.2, and it is severely cramping my style!

--jh--


Comment 6 Havoc Pennington 2002-02-25 23:54:12 UTC
I spent some time looking at zvt code but couldn't figure out what would cause
this. Will look at it more.

Comment 7 Havoc Pennington 2002-03-05 22:22:00 UTC
Should be fixed in gnome-libs-1.4.1.2.90-10

I was looking at the X paste code, but the actual problem was
failure to use write() correctly when sending data to the child 
process inside the terminal.


Note You need to log in before you can comment on or make changes to this bug.