Bug 53084 - Abiword fails to start with a font problem
Abiword fails to start with a font problem
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: abiword (Show other bugs)
roswell
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-03 09:42 EDT by adam.huffman
Modified: 2007-04-18 12:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-08 02:00:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adam.huffman 2001-09-03 09:42:59 EDT
Description of Problem:

AbiWord crashes with a segmentation fault when I start it.  A dialog box
appears referring to a font problem.  

Version-Release number of selected component (if applicable):

0.7.14-7

How Reproducible:

Every time

Steps to Reproduce:
1.Start abiword 
2. 
3. 

Actual Results:

Error dialog box appears then abiword stops with a segmentation fault.

Expected Results:

AbiWord should start normally.

Additional Information:
Comment 1 adam.huffman 2001-09-03 09:53:36 EDT
I've tried to attach a screengrab of the error message, but it isn't working.

The message is:

AbiWord could not load the following font or fontset from the X Window System
display server: [-*-Times New Roman-regular-r-*-*-*-0-*-*-*-*-*-*]

This error could be the result of an incomplete AbiSuite installation, an
incompatibility with your X Window System display server, or a problem
communicating with a remote font server.

Often this error is the result of invoking AbiWord directly instead of through
its wrapper shell script.  The script dynamically adds the AbiSuite font
directory to your X Window System display server font path before running the
executable.

This happens when I invoke AbiWord from the Applications menu or from the
command line.
Comment 2 Owen Taylor 2001-09-04 11:55:46 EDT
What font path does 'xset -q' show after trying to start abiword?
Comment 3 adam.huffman 2001-09-04 12:02:33 EDT
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  auto repeat delay:  660    repeat rate:  25
  auto repeating keys:  00ffffffdffffbbf
                        fa9fffffffdff5ff
                        ffffffffffffffff
                        ffffffffffffffff
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  0    cycle:  0
Colors:
  default colormap:  0x20    BlackPixel:  0    WhitePixel:  65535
Font Path:
 
/usr/X11R6/lib/X11/fonts/misc/,/usr/X11R6/lib/X11/fonts/75dpi/,/usr/X11R6/lib/X11/fonts/100dpi/
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
  Display is not capable of DPMS
Font cache:
  hi-mark (KB): 1024  low-mark (KB): 768  balance (%): 70
Comment 4 Bill Nottingham 2001-09-04 14:47:24 EDT
This looks like your font install is fubar somehow. What does chkfontpath --list
say?
Comment 5 adam.huffman 2001-09-05 07:16:24 EDT
This is from a new installation (not an upgrade), using the latest packages 
from the beta up2date server:

Current directories in font path:
1: /usr/X11R6/lib/X11/fonts/misc:unscaled
2: /usr/X11R6/lib/X11/fonts/75dpi:unscaled
3: /usr/X11R6/lib/X11/fonts/100dpi:unscaled
4: /usr/X11R6/lib/X11/fonts/misc
5: /usr/X11R6/lib/X11/fonts/Type1
6: /usr/X11R6/lib/X11/fonts/Speedo
7: /usr/X11R6/lib/X11/fonts/cyrillic
8: /usr/X11R6/lib/X11/fonts/CID
9: /usr/X11R6/lib/X11/fonts/local
10: /usr/X11R6/lib/X11/fonts/latin2/75dpi:unscaled
11: /usr/X11R6/lib/X11/fonts/latin2/100dpi:unscaled
12: /usr/X11R6/lib/X11/fonts/latin2/Type1
13: /usr/X11R6/lib/X11/fonts/latin2/75dpi
14: /usr/X11R6/lib/X11/fonts/latin2/100dpi
15: /usr/share/fonts/default/TrueType
16: /usr/share/fonts/default/Type1
17: /usr/share/AbiSuite/fonts
Comment 6 Bernhard Rosenkraenzer 2001-11-28 08:14:04 EST
Odd, that should work. Can you check if the problem still exists for you if 
you update to the 0.9.5-1 package currently in rawhide? (You'll need to run 
rpm --rebuild on the source package because of a libpng version change)
Comment 7 adam.huffman 2001-11-28 14:23:57 EST
That package doesn't work either;  the error message is slightly different:

"Warning: AbiWord could not add its fonts to the X font path"

Recently I've been using the package from Havoc Pennington's gnomehide, which 
does work.
Comment 8 Jeremy Katz 2002-07-18 00:46:52 EDT
Okay, the gnomehide package is the basis for the current rawhide packages and it
works for me there, so I'm guessing the problem has been fixed.

Note You need to log in before you can comment on or make changes to this bug.