This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 530899 - lockup during hibernate if running find
lockup during hibernate if running find
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-25 18:54 EDT by Michael De La Rue
Modified: 2010-12-03 22:41 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-03 22:41:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
tarball containing full logs from a system where this was seen. (176.80 KB, application/octet-stream)
2009-10-25 18:54 EDT, Michael De La Rue
no flags Details
entire /var/log from system where bug is seen after more hibernate tests. (240.31 KB, application/octet-stream)
2009-10-30 04:14 EDT, Michael De La Rue
no flags Details
backtrace of a frozen find command after hibernate. (952 bytes, text/plain)
2009-11-18 17:09 EST, Michael De La Rue
no flags Details

  None (edit)
Description Michael De La Rue 2009-10-25 18:54:17 EDT
Created attachment 366051 [details]
tarball containing full logs from a system where this was seen.

Description of problem:
System recovery from hibernate when find is running fails

Version-Release number of selected component (if applicable):


How reproducible:
tested once.  will test again.

Steps to Reproduce:
1. fresh install of Fedora 12 on my core2duo
2. boot up
3. hibernate
4. restart (everything okay)
5. start "find /" 
6. hibernate 
7. try to restart 
  
Actual results:
System boots up to a blank screen.  No virtual consoles seem to be active magic-sysrq-s causes disk activity but afterwards magic-sysrq-b does not cause reboot.  


Expected results:
system should hibernate; find should be suspended; when system recovers, find should continue.  

Additional info:
System is generally stable for multiple days and across full runs of memtest86

Also have Bug #529590 open against fedora 11, but this seems to be different since there is no sign of any problem after the first hibernate and no sign of failing processes in the log.

kernel version appears to be 
2.6.31.1-56.fc12.x86_64

Unfortuanately sosreport isn't working for me right now (like bug 523274) so I just attach the log files in a tarball.  System failure seems to be at 
Oct 25 00:51:21
Comment 1 Michael De La Rue 2009-10-30 04:14:09 EDT
Created attachment 366767 [details]
entire /var/log from system where bug is seen after more hibernate tests.

I've just reproduced this bug with 2.6.31.5-96.fc12.x86_64 however, with the comment that a normal recover from didn't work properly either.  Although the system came up the video signal looked weak / washed out.. 

I think that I should stress that this system is completely stable apart from when I hibernate (runs memtest86 through entire cycle / multi-day uptime / heavy user loads /compilation etc.)

Some interesting times from logs

Oct 30 08:25:37 - boot up
Oct 30 08:25:43 - ivortest kernel: [drm:drm_mode_rmfb] *ERROR* tried to remove a fb that we didn't own
Oct 30 08:28:34 - attempt to hibernate with find running
Oct 30 08:28:34 - restore with find / running 
Oct 30 08:35:55 - forced reboot after lock up
Oct 30 08:38:26 - hibernate with no special load
Oct 30 08:38:27 - seems to be time of restore to working but with a "washed out" video screen
Oct 30 08:39:33 - reboot to beta system from which I'm now reporting this bug
Comment 2 Bug Zapper 2009-11-16 09:19:12 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Michael De La Rue 2009-11-18 17:09:21 EST
Created attachment 370210 [details]
backtrace of a frozen find command after hibernate.

Currently running: 2.6.31.5-96.fc12.x86_64 
though /etc/fedora-release says:
Fedora release 13 (Rawhide)

This problem has improved.  I managed to hibernate and un-hibernate running find and it continued from where it left off.  Then I tried again.  The second time the find process stopped but everything else seems to have continued fine.  I managed to get a backtrace from the find process after the hibernate.  Please see the attachment.  Afterwards the find seemed to respond to a ctrl-C.
Comment 4 Bug Zapper 2010-11-04 05:07:41 EDT
This message is a reminder that Fedora 12 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 12.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '12'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 12's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 12 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Bug Zapper 2010-12-03 22:41:32 EST
Fedora 12 changed to end-of-life (EOL) status on 2010-12-02. Fedora 12 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.