Bug 530906 - [abrt] crash detected in python-2.6.2-2.fc12
[abrt] crash detected in python-2.6.2-2.fc12
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: smolt (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Mike McGrath
Fedora Extras Quality Assurance
abrt_hash:cc8d1271933dd7f325172764c4a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-25 19:41 EDT by Robert Lightfoot
Modified: 2010-02-23 00:32 EST (History)
7 users (show)

See Also:
Fixed In Version: smolt-1.4.2-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-23 00:32:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (11.94 KB, text/plain)
2009-10-25 19:41 EDT, Robert Lightfoot
no flags Details

  None (edit)
Description Robert Lightfoot 2009-10-25 19:41:19 EDT
abrt detected a crash.


How to reproduce
-----
1.
2.
3.


Comment
-----
Installed smolt-gui and launched from menu.

Additional information
======


Attached files
----
backtrace

cmdline
-----
/usr/bin/python /usr/bin/smoltGui 


component
-----
python


executable
-----
/usr/bin/python


kernel
-----
2.6.31.5-96.fc12.i686


package
-----
python-2.6.2-2.fc12


reason
-----
Process was terminated by signal 11
Comment 1 Robert Lightfoot 2009-10-25 19:41:22 EDT
Created attachment 366053 [details]
File: backtrace
Comment 2 Dave Malcolm 2009-10-26 10:58:14 EDT
Thanks for filing this bug report.

From the backtrace, it looks like a problem deep inside the PyQt bindings, when running the smolt-gui executable.

If you run the program from a terminal, is there any output to the terminal? (e.g. error messages).

Reassigning component from "python" to "smolt" (smolt-gui subpackage).
Comment 3 Mike McGrath 2009-10-26 11:37:56 EDT
What version of smolt and qt are running?  I've been unable to reproduce bugs while running smoltGui
Comment 4 Robert Lightfoot 2009-10-26 18:22:14 EDT
(In reply to comment #3)
> What version of smolt and qt are running?  I've been unable to reproduce bugs
> while running smoltGui  

rpm -qa | grep smolt returns following
smolt-1.4.4.fc12.noarch
smolt-gui-1.4.4.fc12.noarch
smolt-firstboot-1.4.4.fc12.noarch

rpm -qa | grep qt returns following
qt-4.5.2-25.fc12.i686
qt-x11-4.5.2-25.fc12.i686
Comment 5 Robert Lightfoot 2009-10-26 18:30:38 EDT
(In reply to comment #2)
> Thanks for filing this bug report.
> 
> From the backtrace, it looks like a problem deep inside the PyQt bindings, when
> running the smolt-gui executable.
> 
> If you run the program from a terminal, is there any output to the terminal?
> (e.g. error messages).
> 
> Reassigning component from "python" to "smolt" (smolt-gui subpackage).  

Relaunched from GUI and it worked - problem is not repeatable even for me.
Comment 6 Dave Malcolm 2009-10-26 18:32:29 EDT
(FWIW, assuming I'm reading the backtrace properly, thread 2 frame 51 seems to be showing a fatal error, and frames 50 up to 7 seem to be cleanup.

The segfault seemed to happen in thread 1, where it's showing a dialog box)
Comment 7 Bug Zapper 2009-11-16 09:19:24 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 8 Mike McGrath 2010-01-26 14:25:46 EST
I believe I've got this problem fixed for smolt but there seems to be an underlying library issue causing the actual segfault.  I'll open a different ticket about that when I can reliably reproduce it.
Comment 9 Fedora Update System 2010-02-04 09:57:59 EST
smolt-1.4.2-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/smolt-1.4.2-1.fc12
Comment 10 Fedora Update System 2010-02-05 19:02:08 EST
smolt-1.4.2-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update smolt'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-1529
Comment 11 Fedora Update System 2010-02-23 00:31:47 EST
smolt-1.4.2-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.