Bug 530945 - Package-kit ask for key but does not import
Package-kit ask for key but does not import
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-10-26 04:41 EDT by Steve
Modified: 2009-11-02 18:57 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-02 18:57:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dialog box (28.06 KB, image/png)
2009-10-26 04:41 EDT, Steve
no flags Details
packagekit.log (108.03 KB, text/plain)
2009-10-26 14:32 EDT, Will Woods
no flags Details

  None (edit)
Description Steve 2009-10-26 04:41:56 EDT
Created attachment 366075 [details]
Dialog box

Description of problem:
Package-kit ask for key but does not import. There is no problem by installing on command line.

Version-Release number of selected component (if applicable):
PackageKit-0.4.9-1.fc11.i586

How reproducible:
Always

Steps to Reproduce:
1. Try to install somewhat from a 3rd party repository 
2. Press "Yes" when Packagekit is asking to import the key
  
Actual results:


Expected results:
Packagekit should import the key after pressing the Yes-button

Additional info:
Comment 1 Will Woods 2009-10-26 14:28:20 EDT
AFAICT after you hit Yes, the transaction just ends - not sure what happened to the original transaction. Here's a partial log from packagekitd:

TI:14:23:09.393	FI:pk-transaction-db.c	FN:pk_transaction_db_init,880
 - job count is now at 2292
TI:14:23:09.393	FI:pk-transaction.c	FN:pk_transaction_set_sender,1616
 - setting sender to :1.549
TI:14:23:09.395	FI:pk-transaction-list.c	FN:pk_transaction_list_create,499
 - uid=500, count=0
TI:14:23:09.395	FI:pk-transaction-list.c	FN:pk_transaction_list_create,523
 - adding transaction 0x8f1630, item 0x913b80
TI:14:23:09.395	FI:pk-engine.c	FN:pk_engine_get_tid,289
 - sending tid: '/2293_dbbcbbde_data'
TI:14:23:09.395	FI:pk-engine.c	FN:pk_engine_reset_timer,185
 - reset timer
TI:14:23:09.395	FI:pk-transaction-db.c	FN:pk_transaction_db_defer_write_job_count_cb,521
 - doing deferred write syncronous
TI:14:23:09.460	FI:pk-transaction.c	FN:pk_transaction_set_locale,4277
 - SetLocale method called: en_US.UTF-8
TI:14:23:09.461	FI:pk-transaction.c	FN:pk_transaction_install_signature,3514
 - InstallSignature method called: A3A882C1, faac;1.28-2.fc12;x86_64;rpmfusion-nonfree-rawhide
TI:14:23:09.462	FI:pk-transaction-list.c	FN:pk_transaction_list_remove_internal,180
 - remove transaction /2293_dbbcbbde_data, item 0x913b80
TI:14:23:09.462	FI:pk-inhibit.c	FN:pk_inhibit_remove,194
 - cannot find item 0x8f1630
TI:14:23:09.462	FI:pk-transaction.c	FN:pk_transaction_dispose,5334
 - emitting destroy /2293_dbbcbbde_data
Comment 2 Will Woods 2009-10-26 14:32:11 EDT
Created attachment 366137 [details]
packagekit.log

full packagekitd --verbose log from attempted update. 

Steps performed are as follows:

0) start up packagekitd
1) start Software Update
2) hit Install Updates
3) get cannot-update-repo-unsigned error code
4) enter root password to install unsigned packages
5) transaction begins
6) get repo_signature_required signal
7) hit Yes on key import dialog
8) transaction ends
9) close Software Update, kill packagekitd
Comment 3 Richard Hughes 2009-10-27 06:00:28 EDT
commit f7ad658d5a5070d08be178cfa9704ca29418c885
Author: Richard Hughes <richard@hughsie.com>
Date:   Tue Oct 27 09:59:01 2009 +0000

    Add the missing InstallSignature role from the backend auto-detection. Fixes rh#530945

:100644 100644 00a4227... d9b7256... M  backends/yum/pk-backend-yum.c
:100644 100644 1e0c7f2... e93f9d8... M  src/pk-backend.c

I'll build a snapshot for F12 today for you to test.
Comment 4 Richard Hughes 2009-10-29 07:02:33 EDT
Please can you try the build of PackageKit here: http://koji.fedoraproject.org/koji/taskinfo?taskID=1776157

You will need to reboot your computer to ensure the packagekitd process has been restarted. Please provide feedback to whether this build fixes this bug. Thanks.

Richard.
Comment 5 Steve 2009-10-29 08:03:02 EDT
Seems to be ok. Testet with gpk-application.
Comment 6 Will Woods 2009-10-29 10:33:15 EDT
Same here - tested with gpk-update-viewer. Works as expected.
Comment 7 Steve 2009-10-30 09:00:57 EDT
Fixed in PackageKit-0.5.4-0.1.20091029git.fc12. Closing.
Comment 8 Will Woods 2009-10-30 12:24:58 EDT
Reopening - this is a F12Blocker. It must not be closed until the fixed package is tagged into f12-final. 

Richard, can you please file a tag request for this package (at https://fedorahosted.org/rel-eng/ or use make tag-request)?

If you prefer, I'll file the request, but rel-eng will need to know what else has changed since PackageKit-0.5.3-1.fc12, and what testing those other changes have received.
Comment 9 Adam Williamson 2009-10-30 17:34:38 EDT
A tag request has already been filed:

https://fedorahosted.org/rel-eng/ticket/2936

up to releng now.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Bill Nottingham 2009-11-02 16:27:52 EST
This has been tagged and will be in tomorrow's (20091103) rawhide - please test with that!
Comment 11 Adam Williamson 2009-11-02 18:57:37 EST
The build that was tested in comments #5 and #6 is the exact build that's been tagged, so closing this as fixed. Please re-open if something goes wrong.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.