Bug 53096 - dhcpcd stalls boot when no cable present.
dhcpcd stalls boot when no cable present.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-03 10:58 EDT by David Woodhouse
Modified: 2014-03-16 22:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-16 23:58:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2001-09-03 10:58:07 EDT
Since updating to Roswell2, booting the machine with no cable connected to
the Ethernet interface prevents it from booting. dhcpcd seems to have an
insanely long timeout. 

Roswell1 would notice that there was no link and behave correctly.

I'm told that this was changed because some network drivers were broken and
were not reporting a link when in fact there was one. Wouldn't it be
possible  to use ethtool or mii-tool on interfaces which support it to
determine whether there's a link or not?
Comment 1 Bill Nottingham 2001-09-03 20:29:30 EDT
Not really, as it isn't really reliable enough (if you use the version of
mii-tool that uses the wrong ioctl, you can't trust it; if you use the version
of mii-tool that uses the *right* ioctl, it doesn't always work right.)
Comment 2 David Woodhouse 2001-09-04 01:24:28 EDT
The right ioctl just got fixed so the kernel actually bothers to copy the
results back to userspace, which it wasn't doing before. #53050 should be
closed, but I think it's waiting for an 'official' build of the fixed kernel
package.

With that fixed, are there any drivers that support the MII ioctls but return
crap? If so, they should probably just have their support for those ioctls removed. 

Otherwise, is it at least possible to lower the timeout on dhcpcd to a more
useful value? I'm not sure what it is at the moment - but it far exceeds the
level of my patience. After leaving the laptop for a few minutes, I hit SysRq-K,
logged in and removed eth0 from modules.conf, and rebooted it.
Comment 3 Bill Nottingham 2004-10-16 23:58:26 EDT
This is fixed, has been for a while.

Note You need to log in before you can comment on or make changes to this bug.