Bug 530976 - [Indic] Default keymap need to set for various languages
Summary: [Indic] Default keymap need to set for various languages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-m17n
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Peng Huang
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-26 11:14 UTC by A S Alam
Modified: 2013-07-03 00:56 UTC (History)
6 users (show)

Fixed In Version: 1.2.0.20091120-1.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-04 18:32:54 UTC


Attachments (Terms of Use)
Fix for default keymap layout selection (2.13 KB, patch)
2009-11-20 04:04 UTC, Parag Nemade
no flags Details | Diff

Description A S Alam 2009-10-26 11:14:40 UTC
Description of problem:
ibus now showing different keymap from Expected (as f11 or f10 has), 
below is list which should be default:
--------


LANG - Current (f12) 	Change Request(->)
as_IN - inscript
bn_IN - inscript
gu_IN - inscript
hi_IN - phenotic         	                    ->Incript
kn_IN - inscript
ml_IN - itrans                             	->inscript
mai_IN - inscript
mr_IN - itrans 	                	->inscript
ne_NP - rom
or_IN - phonetic
pa_IN - itrans  	                                 ->inscript
si_LK - transliteration                             ->wijesekara
ta_IN - Tamil 	99
te_IN - rts  	                                        ->inscript
ur_IN - phonetic

Version-Release number of selected component (if applicable):
ibus-1.2.0.20091014-2.fc12.x86_64
ibus-m17n-1.2.0.20090617-4.fc12.x86_64
How reproducible:


Steps to Reproduce:
1. try to login in different locale with different user 
2. check default keymap
3.
  
Actual results:
it is different than expected 

Expected results:
it should be as in previous release

Additional info:

Comment 1 Peng Huang 2009-10-27 05:34:07 UTC
Do you mean most users want set the inscript keymaps as default?

Comment 2 A S Alam 2009-10-27 05:49:03 UTC
Yes,  it is
one more update:
or_IN  phonetic ->Incscript

Comment 3 A S Alam 2009-10-27 07:39:33 UTC
All Default keymaps available on following link:

http://fedoraproject.org/wiki/I18N/Indic

Comment 4 Peng Huang 2009-10-28 04:47:55 UTC
This problem is because ibus-m17n does provide correct rank value for each keymap. So ibus can not decide which keymap should be the default keymap.

Comment 5 Parag Nemade 2009-11-11 23:27:15 UTC
Hi,
   I have worked on this issue with phuang's help. I have created new scratch build that will fix this issue. you can test this fix by installing new rpms which are available at http://koji.fedoraproject.org/koji/taskinfo?taskID=1800429

Comment 6 A S Alam 2009-11-12 09:11:27 UTC
sorry, but after installing this, ibus is not working after selecting any Indic language, while Right Click on ibus Icon, there is no keymap at all (if I selected hindi, then it is empty)

If go to preference, ->Input method, then Non of Indic language is in list, only CJK or rawcode.

I have fresh installed machine and before installing this package, it was working

Comment 7 Bug Zapper 2009-11-16 14:20:47 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 8 A S Alam 2009-11-20 03:25:03 UTC
Following Build fixed the issue.
http://koji.fedoraproject.org/koji/taskinfo?taskID=1815745
Thanks

Comment 9 Parag Nemade 2009-11-20 04:04:10 UTC
Created attachment 372406 [details]
Fix for default keymap layout selection

Comment 10 Fedora Update System 2009-11-20 06:11:52 UTC
ibus-m17n-1.2.0.20091120-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/ibus-m17n-1.2.0.20091120-1.fc12

Comment 11 Fedora Update System 2009-11-24 07:51:52 UTC
ibus-m17n-1.2.0.20091120-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update ibus-m17n'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-11967

Comment 12 A S Alam 2009-12-04 07:13:35 UTC
This Package Fixed the issue. 
ibus-m17n-1.2.0.20091120-1.fc12

Comment 13 Vedran Miletić 2009-12-04 18:32:54 UTC
The VERIFIED, FAILS_QA and RELEASE_PENDING bug states are not used by Fedora (they are used in the RHEL process).

Closing as WORKSFORME per comment #12.

---

Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 14 Fedora Update System 2009-12-04 23:58:46 UTC
ibus-m17n-1.2.0.20091120-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.