This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 53108 - gettext-0.10.38-7 spec file fix
gettext-0.10.38-7 spec file fix
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gettext (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-03 15:10 EDT by Need Real Name
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-04 11:52:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-09-03 15:10:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010825

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm --rebuild --target i686 gettext-0.10.38-7.src.rpm
2.
3.
	

Actual Results:  RPM build errors:
    File not found by glob:
/var/tmp/gettext-0.10.38-root/usr/share/emacs/site-lisp/*.el*


Additional info:

FIX (since there are no .el* files there): #%{_datadir}/emacs/site-lisp/*.el*
The only .el* file is:
%{_datadir}/emacs/site-lisp/site-start.d/po-mode-init.el
Comment 1 Trond Eivind Glomsrxd 2001-09-04 11:11:27 EDT
There should be an elc file there as well:

[teg@halden teg]$ rpm -ql gettext |grep -E "(el|elc)$"
/usr/share/emacs/site-lisp/po-mode.el
/usr/share/emacs/site-lisp/po-mode.elc
/usr/share/emacs/site-lisp/site-start.d/po-mode-init.el
[teg@halden teg]$ rpm -q gettext
gettext-0.10.38-7
[teg@halden teg]$
Comment 2 Trond Eivind Glomsrxd 2001-09-04 11:52:15 EDT
Sweet. I rebuilt twice. One worked, one didn't.
Comment 3 Trond Eivind Glomsrxd 2001-09-17 11:13:04 EDT
"Fixed" - I moved the el file to the emacs build. Emacs 20.7-42, gettext 0.10.40-1.
Comment 4 Need Real Name 2001-09-17 17:19:03 EDT
Found the probable cause of the problem, a typo in the misc/Makefile. This may
still be interesting information, even though another solution has been found.
(Don't know if the 0.10.40 misc/Makefile has changed from 0.10.38)

Error in build log:
...
mkdir /var/tmp/gettext-0.10.38-root/usr/share/emacs/site-lisp
/bin/sh: @list=po-mode.el: command not found
...

Fix:
Change misc/Makefile:
-
  @list='$(lisp_LISP)'; test '$(EMACS)' = no || for p in $$list; do \
+
  list='$(lisp_LISP)'; test '$(EMACS)' = no || for p in $$list; do \

Note You need to log in before you can comment on or make changes to this bug.