Bug 531095 - ftp client does not support active mode from command line invocation
ftp client does not support active mode from command line invocation
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ftp (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Jiri Skala
Dalibor Pospíšil
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-26 17:10 EDT by Mark Allen
Modified: 2014-11-09 17:32 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-28 08:57:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Actual patch to implement an active mode option (1.45 KB, patch)
2009-10-26 17:10 EDT, Mark Allen
no flags Details | Diff
Updates the ftp RPM spec file to use the active mode patch (876 bytes, patch)
2009-10-26 17:11 EDT, Mark Allen
no flags Details | Diff

  None (edit)
Description Mark Allen 2009-10-26 17:10:01 EDT
Created attachment 366159 [details]
Actual patch to implement an active mode option

Description of problem:
The ftp client does not support selecting an active mode connection from the command line.  This is fine if a human can interactively start the ftp process, but not as desirable when re-platforming a bunch of ftp scripts from other platforms that were all written to use active mode transfer types.

Also some FTP servers just don't support passive mode or don't support it correctly, so it's useful to be able to specify that active mode is desired without having to modify a lot of underlying scripts.

Additional info:
netkit-ftp-0.17-active-mode-option.patch implements the command line option using -A to keep compatibility with other popular enterprise Linux implementations (i.e., SuSE to name one.)

The RPM spec file patch will be added in a moment.
Comment 1 Mark Allen 2009-10-26 17:11:57 EDT
Created attachment 366160 [details]
Updates the ftp RPM spec file to use the active mode patch

This attachment modifies the current netkit-ftp spec file to use the active mode command line option patch.
Comment 9 errata-xmlrpc 2011-11-28 08:57:53 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1480.html

Note You need to log in before you can comment on or make changes to this bug.