Bug 531101 - RHEL 4.7: KVM Virtual Machines dying during suspend to RAM
RHEL 4.7: KVM Virtual Machines dying during suspend to RAM
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Tim Burke
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2009-10-26 17:31 EDT by Lucas Meneghel Rodrigues
Modified: 2015-10-18 18:41 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-13 11:06:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lucas Meneghel Rodrigues 2009-10-26 17:31:53 EDT
Description of problem: KVM guests installed with RHEL 4.7 are dying during sleep

Version-Release number of selected component (if applicable): 

How reproducible: Allways

Steps to Reproduce:
1. Issue the following command
chvt 1 && echo mem > /sys/power/state && chvt 7
to suspend to RAM and then wake up the host
  
Actual results: Virtual machine process (qemu) ends abnormally

Expected results: Virtual machine process (qemu) stays alive and machine comes back from suspend to RAM

Additional info: 

KVM version: v2.6.27-rc8-19504-g2a21c9c (git next branch for rhel 5.4)
KVM userspace version: 0.9.1 (kvm-devel) (git next branch for rhel 5.4)

Problem reproduces on the RHEL development branch, and upstream:

KVM version: v2.6.27-rc8-19515-g1e77cae (git next branch for rhel 5.5)
KVM userspace version: 0.9.1 (kvm-83-maint-snapshot-20090205) (git next branch for rhel 5.5)

KVM version: v2.6.31-rc3-14609-g8543298 (git master upstream)
KVM userspace version: 0.11.50 (qemu-kvm-devel) (git master upstream)

Now we're proceeding to test with RHEL 4.8 to see if problem reproduces.
Comment 1 Ondrej Vasik 2009-10-27 02:14:13 EDT
Thanks for report, but I don't see any connection to coreutils. Could you please explain why you have chosen that component? If not and it is just chosen by accident, please reassign the bugzilla to proper one ( maybe qemu? ). TIA.
Comment 2 Ondrej Vasik 2009-10-31 05:17:46 EDT
Ok, I see no connection to coreutils, so reassigning to kernel (qemu component not present in RHEL-4).
Comment 3 Eduardo Habkost 2009-11-03 09:38:30 EST
Qemu ends abnormally, so it is host bug, not a guest bug. Reassining to RHEL5/kvm.
Comment 10 RHEL Product and Program Management 2011-01-11 15:46:39 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 11 RHEL Product and Program Management 2011-01-11 17:47:31 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Note You need to log in before you can comment on or make changes to this bug.