Bug 53113 - g++ uses all available memory (roswell2)
Summary: g++ uses all available memory (roswell2)
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 9
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-09-03 21:20 UTC by Need Real Name
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-01 23:49:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-09-03 21:20:08 UTC
Description of Problem:



When compiling the file "h225.cxx" from the openh323 package

the compiler makes no progress and just uses up all available

memory (I killed it when it had claimed over 200 MB RAM).


(I compiled the openh323 stuff because I wanted to build the
gnomemeeting application).




Version-Release number of selected component (if applicable):

I use a standard roswell2 beta. (gcc-c++-2.96-96)





How Reproducible:

Compile the openh323-1.6.0-1.src.rpm package which can be found

via http://www.gnomemeeting.org/ (the site is down at the moment

so I can't give exact URLs, sorry).  The openh323 package needs

the pwlib-1.1.36-1.i386.rpm and pwlib-devel-1.1.36-1.i386.rpm

packages installed when building. They build fine from pwlib-1.1.36-1.src.rpm which can be found via the same site.





Steps to Reproduce:

1. rpm --rebuild openh323-1.6.0-1.src.rpm

2. 

3. 



Actual Results:

The build just hangs when g++ is compiling h225.cxx and starts

to consume enormous amount of memory.





Expected Results:





Additional Information:



Here's the g++ commandline:

g++ -Wall -DP_LINUX -D_REENTRANT -DP_HAS_SEMAPHORES -fPIC -DP_SSL -I/usr/include

/include -I/usr/include/crypto -DP_PTHREADS -DPBYTE_ORDER=PLITTLE_ENDIAN -I/home

/robn/rpm/build/openh323/pwlibdir/include/ptlib/unix -DPTRACING -I/home/robn/rpm

/build/openh323/include -DHAS_IXJ -DHAS_OSS -DPTRACING -I/home/robn/rpm/build/op

enh323/pwlibdir/include -O2 -fno-strength-reduce -m486 -malign-loops=2 -malign-j

umps=2 -malign-functions=2  -c /home/robn/rpm/build/openh323/src/h225.cxx -o /ho

me/robn/rpm/build/openh323/lib/obj_linux_x86_r/h225.o


    greetings,
    Rob van Nieuwkerk

Comment 1 Need Real Name 2001-09-04 07:02:44 UTC
Hi,

The gnomemeeting site is up again so I looked up the exact locations
of the source RPMs:

  http://www.gnomemeeting.org/downloads/0.10/redhat/pwlib-1.1.36-1.src.rpm
  http://www.gnomemeeting.org/downloads/0.10/redhat/openh323-1.6.0-1.src.rpm

(as I said before: the packages from the first one are needed for building
the second one.  The reported bug shows when building the second one).

     greetings,
     Rob van Nieuwkerk

Comment 2 Richard Henderson 2004-10-01 23:49:57 UTC
URLS are no longer valid.  After three years I don't expect NEEDINFO
to be useful.  File a new bug report if you still find problems with
current gcc releases.


Note You need to log in before you can comment on or make changes to this bug.