Bug 53117 - installer fails when some file systems are commented out of /etc/fstab
installer fails when some file systems are commented out of /etc/fstab
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
http://www-rcs.ee.washington.edu/~jef...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-03 21:06 EDT by Jeff Silverman
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:48:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Silverman 2001-09-03 21:06:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.74 [en] (X11; U; Linux 2.2.17 i686)

Description of problem:
I was attempting an upgrade from RedHat 6.2 to 7.1.  The installer kept
complaining that I had not shut down the machine cleanly, even though I
am.  In desperation, I commented out some file systems from /etc/fstab.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Comment out all of mount points in /etc/fstab
2.Reboot into the installation CD-ROM		
3.
	

Actual Results:  I cured the problem by uncommenting the mount points for
the swap file and /var and that seemed to cure the problem.

Expected Results:  Ananconda should have complained that it couldn't mount
the file system.

Additional info:
Comment 1 Matt Wilson 2001-09-04 09:37:32 EDT
please attach your /etc/fstab file
Comment 2 Jeff Silverman 2001-09-04 12:05:47 EDT
Here is the current /etc/fstab

[root@truk ~]# more /etc/fstab
/dev/sda7       /               ext2    exec,dev,suid,rw,usrquota 1 1
/dev/sda1       /boot           ext2    defaults        1 2
/dev/sda6       /var            ext2    defaults        1 2
none            /proc           proc    defaults        0 0
none            /dev/pts        devpts  gid=5,mode=620  0 0
/dev/sda5       swap            swap    defaults        0 0
/dev/sdb1       /GNL            ext2    rw
/dev/sdc1       /home           ext2    rw
# Removable media, standard or linux filesystems
/dev/cdrom      /cdrom          iso9660 noauto,ro,user,exec             0 0
/dev/fd0        /fd0            ext2    noauto,user,exec,sync           0 0

# Removable media, DoS/Windoze filesystems
#/dev/fd0       /dos/floppy     msdos   noauto,user,sync                0 0
#
# Connect to the orca cluster read only to get the radar data out.
# orca:/home      /home/httpd/html/spp/orca       nfs     ro


Here is the /etc/fstab when the problem occured:

[root@truk ~]# more /etc/fstab
/dev/sda7       /               ext2    exec,dev,suid,rw,usrquota 1 1
#/dev/sda1       /boot           ext2    defaults        1 2
#/dev/sda6       /var            ext2    defaults        1 2
none            /proc           proc    defaults        0 0
none            /dev/pts        devpts  gid=5,mode=620  0 0
#/dev/sda5       swap            swap    defaults        0 0
#/dev/sdb1       /GNL            ext2    rw
#/dev/sdc1       /home           ext2    rw
# Removable media, standard or linux filesystems
#/dev/cdrom      /cdrom          iso9660 noauto,ro,user,exec             0 0
#/dev/fd0        /fd0            ext2    noauto,user,exec,sync           0 0

# Removable media, DoS/Windoze filesystems
#/dev/fd0       /dos/floppy     msdos   noauto,user,sync                0 0
#
# Connect to the orca cluster read only to get the radar data out.
# orca:/home      /home/httpd/html/spp/orca       nfs     ro

Hope this helps.
Comment 3 Matt Wilson 2001-09-05 20:51:35 EDT
so you weren't using /boot at the time of upgrade?  Or were you trying to keep
the installer from touching it?  Why were you commenting out these entries?

(I'm trying to set up a test case)
Comment 4 Jeff Silverman 2001-09-06 11:59:48 EDT
I was trying to do an upgrade.  I kept getting an error message that the system
had not been shut down cleanly.  But it wouldn't say which file system was not
getting dismounted properly.  So I figured that if I didn't mount most of the
file systems, then I wouldn't have to dismount those file systems.  But that
didn't work, probably because the file system that wasn't getting dismounted
properly was the / file system which is on sda7 if memory serves me. 


Jeff
Comment 5 Matt Wilson 2001-09-06 12:08:20 EDT
you were shutting the machine down cleanly before the upgrade, correct?
Comment 6 Jeff Silverman 2001-09-06 15:47:59 EDT
Yes.
Comment 7 Bryce Nesbitt 2002-01-03 12:26:47 EST
I get the same thing, but with a 7.1->7.2 installation.  The installer claims
that "some filesystems are wrong in fstab" and that the installation can't
continue.  Everything is fine in fstab.
Comment 8 Bryce Nesbitt 2002-01-03 12:27:45 EST
LABEL=/boot         /boot        ext2    defaults        1 2            #
/dev/hde1
#/dev/hde2           /mnt/win98   vfat    defaults        0 0           #
/dev/hde2
#                                                                       #
/dev/hde3 (ext)
#                                                                       #
/dev/hde4 (none)
#/dev/hde5           /mnt/msdos   vfat    defaults,user,umask=000 0 0   #
/dev/hde5
LABEL=/             /            ext2    defaults        1 1            #
/dev/hde6
LABEL=/home         /home        ext2    defaults        1 2            #
/dev/hde7
#/dev/hde8           /mnt/hde8    ext2    defaults        0 0           #
/dev/hde8
#/dev/hde9           /mnt/hde9    ext2    defaults        0 0           #
/dev/hde9
/dev/hde10          swap         swap    defaults        0 0            #
/dev/hde10
#/dev/md0            /mnt/raid0   ext2    defaults        1 2           #
/dev/hde11 12
#/dev/md1            /mnt/raid1   ext2    defaults        1 2           #
/dev/hde8 hdg3
#
none                /proc        proc    defaults        0 0
none                /dev/pts     devpts  gid=5,mode=620  0 0
#
#/dev/hdg1           /mnt/hdg1    ext2    defaults        0 0           #
/dev/hdg1
#/dev/hdg2           /mnt/hdg2    ext2    defaults        0 0           #
/dev/hdg2
#/dev/hdg3           /mnt/hdg3    ext2    defaults        0 0           #
/dev/hdg3
#/dev/hdg5           /mnt/hdg5    ext2    defaults        0 0           #
/dev/hdg5
#/dev/hdg6           /mnt/hdg6    ext2    defaults        0 0           #
/dev/hdg6
#
#/dev/hdc            /mnt/dvdrom  auto noauto,owner,kudzu,ro 0 0
/dev/fd0            /mnt/floppy  auto    noauto,owner    0 0
#
#/dev/sda1           /mnt/flash   vfat    noauto,defaults,user,umask=000 0 0
/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,kudzu,ro 0
0
#/dev/cdrom1             /mnt/cdrom1             iso9660 noauto,owner,kudzu,ro 0
0
Comment 9 Bryce Nesbitt 2002-01-03 12:30:35 EST
It would be terribly handy if it told you WHICH filesystem it can't mount!
Comment 10 Bryce Nesbitt 2002-01-03 15:03:44 EST
It finally worked once I trimmed it down to:
---------------------------------------------------------------------------------------------------
LABEL=/boot             /boot                   ext3    defaults        1 2
LABEL=/             /            ext2    defaults        1 1
LABEL=/home         /home        ext2    defaults        1 2
/dev/hde10          swap         swap    defaults        0 0
none                /proc        proc    defaults        0 0
none                    /dev/shm                tmpfs   defaults        0 0
none                /dev/pts     devpts  gid=5,mode=620  0 0
/dev/fd0            /mnt/floppy  auto    noauto,owner    0 0
/dev/cdrom          /mnt/cdrom   iso9660 noauto,owner,kudzu,ro 0 0
---------------------------------------------------------------------
I think it hated the comments at the end of the line.
Comment 11 Michael Fulbright 2002-03-26 12:27:36 EST
Deferred to future release.
Comment 12 Red Hat Bugzilla 2006-02-21 13:48:07 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.