Bug 531211 - [all_langs]: Lokalize does not render indic characters properly
Summary: [all_langs]: Lokalize does not render indic characters properly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs
Version: 12
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-27 10:28 UTC by Shankar Prasad
Modified: 2015-04-21 04:34 UTC (History)
14 users (show)

Fixed In Version: 4.3.4-1.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-28 20:08:51 UTC


Attachments (Terms of Use)
broken rendering of indic characters in lokalize (320.78 KB, image/x-xcf)
2009-10-27 10:28 UTC, Shankar Prasad
no flags Details
snapshot that shows correct font rendering (60.55 KB, image/jpeg)
2009-11-20 16:42 UTC, Ngo Than
no flags Details
broken-kn-rendering.png (83.61 KB, image/png)
2009-11-22 06:57 UTC, Parag Nemade
no flags Details
broken rendering on Fedora 12 (83.76 KB, image/png)
2009-11-23 05:39 UTC, Parag Nemade
no flags Details
Screenshot for wrong rendering of Malayalam on F12 (94.24 KB, image/png)
2009-11-23 07:36 UTC, Ani Peter
no flags Details
This is what I get on F-12 (98.47 KB, image/png)
2009-12-18 06:47 UTC, Parag Nemade
no flags Details
This is what I get on F-13 (66.21 KB, image/png)
2009-12-18 06:48 UTC, Parag Nemade
no flags Details

Description Shankar Prasad 2009-10-27 10:28:58 UTC
Created attachment 366229 [details]
broken rendering of indic characters in lokalize

Description of problem:
Translation tool loakize doesn't render kn (all indic as well) characters properly.

Version-Release number of selected component (if applicable):
kdesdk-4.3.2-2.fc12

How reproducible:


Steps to Reproduce:
1.Install the kdesdk package
2.Open any translated po file (for example http://l10n.gnome.org/vertimus/pessulus/master/po/kn)
3.Look at the Kannada characters in msgstr field
  
Actual results:
Does not render properly. Dotted circles are appearing.

Expected results:
Should render properly

Additional info:
Tried to switch the language using Help -> Switch Application Language, but couldn't see Kannada in the dropdown box.Finally we could able to resolve this issue locally by having a empty file lokalize.mo in /usr/share/loacales/kn/LC_messages.

Comment 1 Bug Zapper 2009-11-16 14:24:13 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Ngo Than 2009-11-17 13:24:18 UTC
i cannot reproduce this issue with qt-4.5.3-9. Could you please try again with qt-4.5.3-9? thanks

Comment 3 Shankar Prasad 2009-11-18 07:42:29 UTC
Than,

I tried the lokalize with the qt-4.5.3-9 itself. By the way did you tried with the .po file which contain any indic text?

As I said in the additional info, I could resolve this issue by just creating a empty file called lokalize.mo in /usr/share/locales/kn/LC_messages folder.

Comment 4 Shankar Prasad 2009-11-18 08:00:44 UTC
By the way, I doubt this is anything to do with qt, does it?

Comment 5 Steven M. Parrish 2009-11-19 20:38:07 UTC
This bug has been triaged

Comment 6 Ngo Than 2009-11-20 16:42:06 UTC
Created attachment 372537 [details]
snapshot that shows correct font rendering

i really cannot reproduce this issue with latest qt in F12. I attach a snapshot that shows the correct rendering with kn language. It could be that some fonts are missing on your machine. Could you please check again? thanks

Comment 7 Parag Nemade 2009-11-22 06:53:11 UTC
I still see problem exists on F-12. Also, I have F-10 with latest qt-4.5.3-9 machine now with me and tried to work on this issue but still problem exists.

1)can you tell us what locale environment you used to test?
2)qt and any other package version related to this?

Comment 8 Parag Nemade 2009-11-22 06:57:08 UTC
Created attachment 372865 [details]
broken-kn-rendering.png

I tried to check kn.po rendering in lokalize application in English as well as Kannada locale but same broken rendering results on F-10.

Will post F-12 results soon.

Comment 9 Parag Nemade 2009-11-23 05:39:48 UTC
Created attachment 373021 [details]
broken rendering on Fedora 12

Than,
   I tried to reproduce same screenshot that you got on F-12 machine but here is what I got, still broken rendering.

Comment 10 Ani Peter 2009-11-23 07:36:16 UTC
Created attachment 373031 [details]
Screenshot for wrong rendering of Malayalam on F12

Attaching a screenshot for Malayalam (ml-IN) on F12.
Here you can see the rendering still breaks for Malayalam in the msgstr section.

The packages installed:
kdesdk-4.3.2-2.fc12.i686
qt-4.5.3-9.fc12.i686

Comment 11 Amitakhya Phukan 2009-11-23 08:10:35 UTC
Hello,

Right click on any word and de-select auto spell-check. Worked for Assamese. :)

Thanks.

Comment 12 Parag Nemade 2009-11-23 08:21:11 UTC
(In reply to comment #11)
> Hello,
> 
> Right click on any word and de-select auto spell-check. Worked for Assamese. :)
> 
> Thanks.  

Wow! I was not knowing this thing. Thanks Amitakhya.


Than,
   I can summarize now problem looks to be with spell checker in KDE applications.
Same thing can be observed with kwrite application which shows incorrect rendering in spell checker dialog box.

Comment 13 Parag Nemade 2009-11-26 11:26:29 UTC
Than Ping

Comment 14 Ngo Than 2009-11-26 11:56:02 UTC
Parag, it looks like a bug in kde in this case. Could you please report it to KDE upstream?
thanks

Comment 15 Parag Nemade 2009-12-17 09:05:42 UTC
Than,
   can you please backport fix http://websvn.kde.org/?view=revision&revision=1056377 ?

Comment 16 Rex Dieter 2009-12-17 13:00:38 UTC
That will land with our kde-4.4 update.

Comment 17 Kevin Kofler 2009-12-17 14:54:48 UTC
Do we really need to wait 2 months for this to be fixed?

Comment 18 Ngo Than 2009-12-17 15:02:19 UTC
Parag, could you please try to test KDE-4.3.80 in rawhide if it's really fixes the issue before we want to try the backport?

thanks

Comment 19 Parag Nemade 2009-12-18 06:47:42 UTC
Created attachment 379157 [details]
This is what I get on F-12

Comment 20 Parag Nemade 2009-12-18 06:48:21 UTC
Created attachment 379158 [details]
This is what I get on F-13

Comment 21 Parag Nemade 2009-12-18 06:49:14 UTC
(In reply to comment #18)
> Parag, could you please try to test KDE-4.3.80 in rawhide if it's really fixes
> the issue before we want to try the backport?
> 
> thanks  

I see that this issue is fixed in rawhide.

Comment 22 Parag Nemade 2009-12-18 06:57:35 UTC
I have also running custom build kdelibs-4.3.3-5.1.fc12.src.rpm using patch kdelibs-4.3.3-sonnect_indic.patch and srpm which is available at http://paragn.fedorapeople.org/kde-work/

thanks.

Comment 23 Ngo Than 2009-12-18 11:25:40 UTC
Parag, could you please try the new kdelisb from
http://koji.fedoraproject.org/koji/taskinfo?taskID=1879228 ?

Thanks

Comment 24 A S Alam 2009-12-21 04:35:09 UTC
Following Updated Package (#23) Fixed the problem:
kdelibs-4.3.4-3.fc12

Comment 25 Parag Nemade 2009-12-21 04:46:53 UTC
Thanks aalam for testing new kdelibs.

Than,
   I confirm this new update of kdelibs fixed this bug.

Comment 26 Fedora Update System 2009-12-22 04:41:16 UTC
kde-l10n-4.3.4-1.fc11, soprano-2.3.1-1.fc11, kdeaccessibility-4.3.4-1.fc11, kdeadmin-4.3.4-2.fc11, kdeartwork-4.3.4-1.fc11, kdebindings-4.3.4-1.fc11, kdebase-4.3.4-1.fc11, kdebase-runtime-4.3.4-2.fc11, kdebase-workspace-4.3.4-1.fc11, kdeedu-4.3.4-1.fc11, kdegames-4.3.4-1.fc11, kdegraphics-4.3.4-1.fc11, kdelibs-experimental-4.3.4-1.fc11, kdemultimedia-4.3.4-1.fc11, kdenetwork-4.3.4-1.fc11, kdepim-4.3.4-1.fc11, kdepim-runtime-4.3.4-1.fc11, kdeplasma-addons-4.3.4-1.fc11, kdesdk-4.3.4-1.fc11, kdetoys-4.3.4-1.fc11, kdeutils-4.3.4-1.fc11, kde-settings-4.2-14, oxygen-icon-theme-4.3.4-1.fc11, kdepimlibs-4.3.4-1.fc11, kdelibs-4.3.4-3.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kde-l10n soprano kdeaccessibility kdeadmin kdeartwork kdebindings kdebase kdebase-runtime kdebase-workspace kdeedu kdegames kdegraphics kdelibs-experimental kdemultimedia kdenetwork kdepim kdepim-runtime kdeplasma-addons kdesdk kdetoys kdeutils kde-settings oxygen-icon-theme kdepimlibs kdelibs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-13342

Comment 27 Fedora Update System 2009-12-22 04:52:05 UTC
kde-l10n-4.3.4-1.fc12, kdeutils-4.3.4-2.fc12, kdetoys-4.3.4-1.fc12, kdesdk-4.3.4-1.fc12, kdepim-runtime-4.3.4-1.fc12, kdepim-4.3.4-1.fc12, kdeplasma-addons-4.3.4-1.fc12, kdenetwork-4.3.4-1.fc12, kdemultimedia-4.3.4-1.fc12, kdegraphics-4.3.4-1.fc12, kdegames-4.3.4-1.fc12, kdeedu-4.3.4-1.fc12, kdebindings-4.3.4-1.fc12, kdeartwork-4.3.4-1.fc12, kdeadmin-4.3.4-1.fc12, kdeaccessibility-4.3.4-1.fc12, kdebase-runtime-4.3.4-2.fc12, kdebase-4.3.4-1.fc12, kdepimlibs-4.3.4-1.fc12, kdelibs-experimental-4.3.4-1.fc12, phonon-4.3.80-2.fc12, kde-settings-4.3-15.1, oxygen-icon-theme-4.3.4-1.fc12, kdelibs-4.3.4-3.fc12, kdebase-workspace-4.3.4-3.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kde-l10n kdeutils kdetoys kdesdk kdepim-runtime kdepim kdeplasma-addons kdenetwork kdemultimedia kdegraphics kdegames kdeedu kdebindings kdeartwork kdeadmin kdeaccessibility kdebase-runtime kdebase kdepimlibs kdelibs-experimental phonon kde-settings oxygen-icon-theme kdelibs kdebase-workspace'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-13285

Comment 28 Fedora Update System 2009-12-28 20:08:29 UTC
kde-l10n-4.3.4-1.fc12, kdeutils-4.3.4-2.fc12, kdetoys-4.3.4-1.fc12, kdesdk-4.3.4-1.fc12, kdepim-runtime-4.3.4-1.fc12, kdepim-4.3.4-1.fc12, kdeplasma-addons-4.3.4-1.fc12, kdenetwork-4.3.4-1.fc12, kdemultimedia-4.3.4-1.fc12, kdegraphics-4.3.4-1.fc12, kdegames-4.3.4-1.fc12, kdeedu-4.3.4-1.fc12, kdebindings-4.3.4-1.fc12, kdeartwork-4.3.4-1.fc12, kdeadmin-4.3.4-1.fc12, kdeaccessibility-4.3.4-1.fc12, kdebase-runtime-4.3.4-2.fc12, kdebase-4.3.4-1.fc12, kdepimlibs-4.3.4-1.fc12, kdelibs-experimental-4.3.4-1.fc12, phonon-4.3.80-2.fc12, kde-settings-4.3-15.1, oxygen-icon-theme-4.3.4-1.fc12, kdelibs-4.3.4-3.fc12, kdebase-workspace-4.3.4-3.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 29 Fedora Update System 2009-12-28 20:11:13 UTC
kde-l10n-4.3.4-1.fc11, soprano-2.3.1-1.fc11, kdeaccessibility-4.3.4-1.fc11, kdeadmin-4.3.4-2.fc11, kdeartwork-4.3.4-1.fc11, kdebindings-4.3.4-1.fc11, kdebase-4.3.4-1.fc11, kdebase-runtime-4.3.4-2.fc11, kdebase-workspace-4.3.4-1.fc11, kdeedu-4.3.4-1.fc11, kdegames-4.3.4-1.fc11, kdegraphics-4.3.4-1.fc11, kdelibs-experimental-4.3.4-1.fc11, kdemultimedia-4.3.4-1.fc11, kdenetwork-4.3.4-1.fc11, kdepim-4.3.4-1.fc11, kdepim-runtime-4.3.4-1.fc11, kdeplasma-addons-4.3.4-1.fc11, kdesdk-4.3.4-1.fc11, kdetoys-4.3.4-1.fc11, kdeutils-4.3.4-1.fc11, kde-settings-4.2-14, oxygen-icon-theme-4.3.4-1.fc11, kdepimlibs-4.3.4-1.fc11, kdelibs-4.3.4-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.