Bug 53126 - incorrect error messages from more
incorrect error messages from more
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Elliot Lee
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-04 00:38 EDT by Chris Ricker
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-04 00:38:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2001-09-04 00:38:49 EDT
In Red Hat 7.1 and prior releases, as well as in other Unixen, attempting
to run more on a file which the user does not have permission to access
results in the logical error message "permission denied."

Some time during the betas, this was broken.  more now reports "illegal
seek" when users try to use more as a page for files for which they don't
have read permission.

This is a regression from prior releases.

RH 7.1:

[kaboom@hanuman kaboom]$ ls -l /tmp/foo
-rw-------    1 root     root        12636 Sep  3 22:49 /tmp/foo
[kaboom@hanuman kaboom]$ more /tmp/foo 
/tmp/foo: Permission denied
[kaboom@hanuman kaboom]$ id
uid=500(kaboom) gid=500(kaboom) groups=500(kaboom),10(wheel)
[kaboom@hanuman kaboom]$ 

RC2:

[kaboom@verdande kaboom]$ ls -l /boot/grub/grub.conf 
-rw-------    1 root     root          667 Aug 31 19:36 /boot/grub/grub.conf
[kaboom@verdande kaboom]$ more /boot/grub/grub.conf 
/boot/grub/grub.conf: Illegal seek
[kaboom@verdande kaboom]$ id
uid=500(kaboom) gid=500(kaboom) groups=500(kaboom),10(wheel)
[kaboom@verdande kaboom]$ sudo more /boot/grub/grub.conf 
# grub.conf generated by anaconda
#
<snip rest of output>
Comment 1 Elliot Lee 2002-01-04 13:06:29 EST
I can't reproduce this with util-linux-2.11n-1 from rawhide, running 'more
/etc/shadow'.

Note You need to log in before you can comment on or make changes to this bug.