Bug 531407 - --encrypted option does not work with pv in kickstart script
--encrypted option does not work with pv in kickstart script
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
NeedsRetesting
:
Depends On: 510545
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-10-28 00:59 EDT by Huzaifa S. Sidhpurwala
Modified: 2010-01-06 20:42 EST (History)
5 users (show)

See Also:
Fixed In Version: anaconda-12.40-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-06 20:42:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Huzaifa S. Sidhpurwala 2009-10-28 00:59:46 EDT
I am using the following options 

--encrypted --passphrase=foo --escrowcert http://hostname/cert.crt --backuppassphrase

When i use this with autopart in the kickstart it works and the pv is encrypted.
But when i use this with 
part --grow --size=1 pv.20 as

"part --grow --size=1 pv.20 --encrypted --passphrase=foo --escrowcert http://hostname/cert.crt --backuppassphrase"

it freaks out, with the following back trace.

File "/usr/lib/anaconda/kickstart.py", Line 751 in parse
if pd.preexist:
    AttributeError: "F12_PartData" object has not attribute preexist


I am using F12-beta
Comment 1 Miloslav Trmač 2009-10-28 01:19:54 EDT
I have submitted something like the following:

@@ -749,7 +749,7 @@ class Partition(commands.partition.F12_Partition):
                storage.encryptionPassphrase = pd.passphrase
 
             cert = getEscrowCertificate(self.handler.anaconda, pd.escrowcert)
-            if pd.preexist:
+            if pd.onPart:
                 luksformat = format
                 device.format = getFormat("luks", passphrase=pd.passphrase, device=device.path,
                                           escrow_cert=cert,


as part of the escrow patches in #510545, but it was dropped - see comment #11 in that bug.
Comment 2 Adam Williamson 2009-10-28 17:08:52 EDT
A build of anaconda 12.40, which should address this issue, is currently in progress: http://koji.fedoraproject.org/koji/buildinfo?buildID=138787

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 3 Adam Williamson 2009-10-29 13:50:06 EDT
anaconda 12.41 was tagged into Rawhide today. a net install from a Rawhide tree updated to today's packages, or a nightly build dated 20091029 or later, should have this fix (make sure the installer says anaconda version 12.41). if you could confirm the fix, that'd be great. thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Adam Williamson 2009-10-30 12:50:27 EDT
Discussed at the blocker bug meeting today. We agreed this isn't really a blocker, so dropping to target, but the fix stays in since it's in already. If it's not fully fixed, though, we won't block release.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.